YesNoOk
avatar

No Sound Windows 7 (Read 3309 times)

Started by Lactis, December 08, 2010, 08:04:40 am
Share this topic:
No Sound Windows 7
#1  December 08, 2010, 08:04:40 am
  • avatar
OK to start off I download Mugen 100%. Everything works fine except the sound. There is no sound at all. All and any help appreciated.

Also sorry if this has been posted. I did search, but may be missed it.
Re: No Sound Windows 7
#2  December 08, 2010, 03:13:29 pm
  • ***
  • Life is Life... WTF!!
    • www.mugenimperiolatino.com/index.php
Open your mugen.cfg and look for the next line:

[Sound]
  ;Set the following to 1 to enable sound effects and music.
  ;Set to 0 to disable.
Sound = 1

Set this value with "1" like in example... i thing could be that.  :sugoi:

byebye!
[

Nice userbars no? :P Make click & Download something nice for your Mugen!!!
________________________________
Re: No Sound Windows 7
#3  December 08, 2010, 07:29:39 pm
  • avatar
It's already set to 1 so that can't be the problem, but thanks anyway. Anybody else have any ideas?
Re: No Sound Windows 7
#4  December 08, 2010, 10:07:55 pm
  • ***
  • Life is Life... WTF!!
    • www.mugenimperiolatino.com/index.php
[

Nice userbars no? :P Make click & Download something nice for your Mugen!!!
________________________________
Re: No Sound Windows 7
#5  December 08, 2010, 10:54:16 pm
  • avatar
Tried the plugin but now I get a "Assert Failure in init.c Line 596"
Re: No Sound Windows 7
#6  December 09, 2010, 04:11:42 am
  • ***
  • Life is Life... WTF!!
    • www.mugenimperiolatino.com/index.php
pluguin? i didn't say nothing about plugins  :o
[

Nice userbars no? :P Make click & Download something nice for your Mugen!!!
________________________________
Re: No Sound Windows 7
#7  December 09, 2010, 04:34:58 am
  • avatar
My bad ignore the plugin part :P, but thats what I get after putting that file in the data folder and trying to load mugen.
Re: No Sound Windows 7
#8  December 09, 2010, 04:44:53 am
  • ***
  • Life is Life... WTF!!
    • www.mugenimperiolatino.com/index.php
 :o interesting XD im using that mugen.cfg in to my mugen 1.0... look i read some "unused" values in the eof. these lines are from winmugen... try deleting them.. and check if the error happens again.

ps: did you try download and run the empty/new mugen? just for know if your w7 is incompatible with mugen 1.0...
[

Nice userbars no? :P Make click & Download something nice for your Mugen!!!
________________________________
Re: No Sound Windows 7
#9  December 09, 2010, 06:10:18 am
  • avatar
OK I tried the new mugen and it worked fine with sound and everything. I tried copying over my characters from the other mugen along with all the the other folders, but it just it just loads like regular, also where is the "eof" you where talking about? But if that doesn't work then I guess I just have to start all over with the new one. But thanks for the help so far.

Also I heard that the mugen isn't compatible with a lot of the older stuff, so would I have to get only the newest versions of characters and stages?
Re: No Sound Windows 7
#10  December 09, 2010, 07:00:49 am
  • ***
  • Life is Life... WTF!!
    • www.mugenimperiolatino.com/index.php
[

Nice userbars no? :P Make click & Download something nice for your Mugen!!!
________________________________
Re: No Sound Windows 7
#11  December 09, 2010, 07:30:13 am
  • avatar
To be honest I don't know what version I'm using :sugoi:. I just downloaded it from a torrent when I googled a mugen pack to download with characters and stages already added. Also I guess this is from my log "M.U.G.E.N ver 2002.04.14 status log"
Re: No Sound Windows 7
#12  May 04, 2013, 02:04:58 am
  • avatar
    • New Zealand
    • djfalkenal@walla.com
Ok this worked for me, edit your cfg file, works also in windows 8 - just replace this for sound for windows section in mugen.cfg you could toggle stereo effects on again thats ok. goodluck

; Sound configuration (Windows)
; Note: WavVolume and MidiVolume here are not the same
; as the ones in [Options], but they all affect the volume.
[Sound Win]
  ;Set the following to 1 to enable sound effects and music.
  ;Set to 0 to disable.
Sound = 1

  ;Set the following to 1 to enable stereo effects in-game
  ;Set to 0 to disable.
StereoEffects = 0

  ;This is the width of the sound panning field. If you
  ;Increase this number, the stereo effects will sound
  ;closer to the middle. Set to a smaller number to get
  ;more stereo separation on sound effects.
  ;Only valid if StereoEffects is set to 1.
PanningWidth = 240

  ;Set the following to 1 to reverse left and right channels
  ;on your sound card.
ReverseStereo = 0

  ;Wave device to use. Choose from:
  ; NONE    - No wave device
  ; AUTO    - Autodetect
  ; DX?     - DirectSound: replace ? with a the device number (from 0 to 9)
  ; DXA?    - DirectSound with Allegro mixer: replace ? with a the device number (from 0 to 9)
  ; WAVEOUTA- High-quality wave-out
  ; WAVEOUTB- Low-quality wave-out
WavDevice = AUTO

  ;Voice Channels to use. Values are from 1 to 16.
  ;If sound quality is poor, try setting a smaller number, such as 8 or 4.
WavChannels = 12

  ;Maximum number of voices used for MODs.  This number reduces the
  ;number of available WavChannels.  ModVoices must be less than
  ;WavChannels.  If equal, then MODs will get all the available
  ;channels and therefore no sound effects will play.
ModVoices = 6

  ;Midi device to use. Choose from:
  ; NONE    - No midi device
  ; AUTO    - Autodetect
  ; MAPPER  - MIDI Mapper
  ; MID?    - MIDI Device: replace ? with a the device number (from 0 to 9)
  ; DIGMID  - Allegro's Digimid driver
MidiDevice = Mapper

  ;This is the master volume for all wav sounds (affects mp3 volume).
  ;Valid values are from from 0 to 255.
MasterWavVolume = 255

  ;Set the volume of wav, midi, mods and CD audio.
  ;Note: WavVolume does not affect mp3 or mod volume.
  ;Valid values are from from 0 to 255.
  ;For CDAVolume only, using -1 will leave the volume unchanged.
WavVolume = 150
MidiVolume = 150
MP3Volume = 180  ;This affects all Winamp-compatible plugins as well
ModVolume = 150
CDAVolume = 150

  ;Set the following to 1 to enable and 0 to disable MIDI, MP3, MOD and CD
  ;playback.
PlayMIDI = 1
PlayMP3 = 1      ;This affects all Winamp-compatible plugins as well
PlayMOD = 1
PlayCDA = 0

  ;Set the drive letter of your CD-ROM (if you have more than one
  ;drive). eg, To use drive E, put the following:
  ;  CDADevice = E:\
  ;Leave blank to use your default CD-ROM drive.
CDADevice =

  ;Set the following to 1 to pause BGM playback when switching
  ;away from the MUGEN window.
PauseBGMOnDefocus = 1

  ;List Winamp-compatible plugins here.
  ;Specify the filename of the plugin and the list of file types to
  ;use the plugin for. One plugin per line.
  ;Example: plugin = plugins/my_plugin.dll, mp3, mp2, mpg
  ;
  ;If music is not looping with a particular plugin, you can try an
  ;optional first argument looptype=1 (seek to zero; may stutter)
  ;or looptype=1 (reload plugin; slow).
  ;Example: plugin = looptype=2, plugins/my_plugin.dll, mp3, mp2, mpg
;plugin = looptype=2, plugins/in_mad.dll,  mp3, mp2, mpg
plugin = looptype=2, plugins/dj-van.dll,  mp3, mp2, mpg
;plugin = looptype=2, plugins/in_mp3pro.dll,  mp3, mp2, mpg