YesNoOk
avatar

Negative Edge - No Delay Detection!!! (Read 11413 times)

Started by Messatsu, January 24, 2004, 06:12:52 am
Share this topic:
Re: Negative Edge - No Delay Detection!!!
#21  May 26, 2006, 05:32:30 am
  • ******
  • In after lock
    • mugenguild.com/~messatsu/index.html
My email is in my profile. ;)


Many people risk their lives everyday by having Mugen.
Re: Negative Edge - No Delay Detection!!!
#22  May 27, 2006, 04:20:02 am
  • ******
    • network.mugenguild.com/pots/
I was close. ;)
warusaki also started using it after you pointed it out

but i think that 2/3 button negative edge is only worth the trouble for moves like birdie's or bison/balrog's "hold then release 3p"
Use anything you want from my works.  If you need to contact me use email, not private messages.
Re: Negative Edge - No Delay Detection!!!
#23  May 27, 2006, 04:29:24 am
  • ******
  • In after lock
    • mugenguild.com/~messatsu/index.html
I don't have any of his characters anymore, but I remember him not having the 2/3 buttons (which is what I'm referring to).  But I could be wrong.


Many people risk their lives everyday by having Mugen.
Re: Negative Edge - No Delay Detection!!!
#24  May 27, 2006, 10:52:50 am
  • ******
  • Limited time to use Infinite power !
    • France
    • network.mugenguild.com/cybaster/
Quicky checked the code of two of his chars, and yes he had started adding negative edge, but only for the one-button commands.
Re: Negative Edge - No Delay Detection!!!
#25  May 27, 2006, 11:34:55 am
  • ******
Most of his chars don't have 2 button commands - except for dodge/power charge etc. but I'm not sure these ones should.
If I struggled to the end of my determination, to the end of my way of life with my followers, if the result is ruin, then this ruin is inevitable. Grieve. Shed tears. But you cannot regret.
Re: Negative Edge - No Delay Detection!!!
#26  May 28, 2006, 08:19:15 pm
  • ******
  • In after lock
    • mugenguild.com/~messatsu/index.html
Nope, I can send the command file to you if need be though.
AHAHA  I can't figure out what the heck is wrong with it.  It's supposed to update buttons, but it doesn't on yours.  I just checked my old Goki and they work completely different. o_O  

You just so happened to rewrite my code ("ha" as "holda" and var(9) as var(21)) that you extended beyond the max command string length and ended up having suitable code right exactly where the max ended up being, so Mugen never complained.  This truncated part of the code leading to bad values. ><

This is what I have fitting in your character's code that works as I've documented. ^_^;  Keep in mind though that the original values you had no longer work and that the codes should have the bitwise &'s in them.
Code:
; - Reset // Release // Hold
[State -3, Negative Edge]
type = NULL
trigger1 = (var(21)&4032)
trigger1 = (var(21):= 0)
trigger2 = var(21)
trigger2 = (var(21):=var(21)+64*(var(21)&1&&command!="holda")+128*(var(21)&2&&command!="holdb")+256*(var(21)&4&&command!="holdc")+512*(var(21)&8&&command!="holdx")+1024*(var(21)&16&&command!="holdy")+2048*(var(21)&32&&command!="holdz"))-var(21)
trigger3 = var(21):= var(21)-(var(21)&63) + 1*(command = "holda") +2*(command = "holdb") +4*(command = "holdc") +8*(command = "holdx") +16*(command = "holdy") +32*(command = "holdz")

And btw, writing [state -3] doesn't make it checked in -3 states.  It needs to be under [statedef -3] and not preceded by another [statedef **]. :P  Edit: ROAR!! table stretching.  And another thing, something like this takes care of one-button commands:
Code:
[Command]
name = "alphacounterR"
command = ~B, DB, D, ~z
 The -1 code is for 2/3/4/5/6 button simultaneous releases since Mugen won't take care of that on it's own.  So this isn't needed:
Quote
triggerall = command = "hkick_a" || (command = "hkick_aR" && var(21)=65)
In the one-button release commands.


Many people risk their lives everyday by having Mugen.
Last Edit: May 28, 2006, 08:34:17 pm by V for Valodim
Re: Negative Edge - No Delay Detection!!!
#27  May 28, 2006, 11:20:12 pm
  • ******
  • In after lock
    • mugenguild.com/~messatsu/index.html
This version of the code is slightly better.
Code:
[State -1, Negative Edge]; - Reset // Release // Hold
type     = null
trigger1 = var(9)&4032
trigger1 = (var(9):= var(9) - var(9)^4032)*0
trigger2 = var(9)&63
trigger2 = (var(9):= var(9) +64*(var(9)&1 && command != "ha") +128*(var(9)&2 && command != "hb") +256*(var(9)&4 && command != "hc") +512*(var(9)&8 && command != "hx") +1024*(var(9)&16 && command != "hy") +2048*(var(9)&32 && command != "hz")) - var(9)
trigger3 = var(9):= var(9)-(var(9)&63) + 1*(command = "ha") + 2*(command = "hb") + 4*(command = "hc") + 8*(command = "hx") + 16*(command = "hy") + 32*(command = "hz")
The change is that it no longer resets what keys were previously held during a release.  Instead of taking two ticks to "recover" from a release, it now takes one.  But it won't allow tick-sequential releases for some reason though. o_O  Replacing this sctrl for the one that it is most similar to will keep the rest of the things intact.  Only this sctrl changes if you choose to update.


Many people risk their lives everyday by having Mugen.
Re: Negative Edge - No Delay Detection!!!
#28  May 29, 2006, 02:44:38 am
  • avatar
  • *
I had Statedef -3 in there because it used to be in statedef -3 and I was too lazy to change it back to -1 when I C&Ped it XD.

And I know that takes care of 1-button commands fine; but I went to the trouble to implement it.  I sure as heck am not going to just use it for 4 super states XD.

I'll play with the code you posted.  Thanks, Messatsu!

Edit: On further tests, I'm still running into the same sort of issue :\.  It passes var(21) = 2304 and var(21)&2304 fine, but if I use var(21)&2304=2304, I get nothing.  I'm gonna try the improved version and see how that goes.

Edit 2: The new code has a similar issue; what in the heck could my Ken be doing to screw this up? @_@  It's endlessly weird.
Watch me implement it in Ryu and magically, it updates the buttons like it's supposed to :\
Last Edit: May 29, 2006, 03:22:58 am by LimitedMoon
Re: Negative Edge - No Delay Detection!!!
#29  May 29, 2006, 03:39:55 am
  • ******
  • In after lock
    • mugenguild.com/~messatsu/index.html
Upload current version please. ;P


Many people risk their lives everyday by having Mugen.
Re: Negative Edge - No Delay Detection!!!
#30  June 01, 2006, 09:31:44 pm
  • ****
  • 君の事、マスターにしてあげる! 御願い、信じてマスター!♥
    • Philippines
    • Skype - o_hermanm
    • www.rotbrc.com
Also please kepe the consistency on the NE code. I don't know whose NE code to use, and which is proven to work. <_<
Orochi Herman: MUGEN Creator, Producer and Web Programmer
https://www.facebook.com/OrochiHerman/
Re: Negative Edge - No Delay Detection!!!
#31  June 01, 2006, 09:47:33 pm
  • ******
  • In after lock
    • mugenguild.com/~messatsu/index.html
Should I restart the topic?  Reply #26 is the best and probably last version.


Many people risk their lives everyday by having Mugen.
Re: Negative Edge - No Delay Detection!!!
#32  June 01, 2006, 09:56:51 pm
  • ****
  • 君の事、マスターにしてあげる! 御願い、信じてマスター!♥
    • Philippines
    • Skype - o_hermanm
    • www.rotbrc.com
If you can, do so please. And label the snippets that are proven to work so that people interested in NEs won't be confused.

Gimme a yell over PM when you do, then I'll sticky it.
Orochi Herman: MUGEN Creator, Producer and Web Programmer
https://www.facebook.com/OrochiHerman/
Re: Negative Edge - No Delay Detection!!!
#33  June 01, 2006, 10:22:02 pm
  • ******
  • In after lock
    • mugenguild.com/~messatsu/index.html
I don't think it needs to be stickied. :P


Many people risk their lives everyday by having Mugen.