YesNoOk
avatar

Widescreen stages rendering incorrectly on 1.1 (Read 527 times)

Started by Norik, October 05, 2019, 08:36:57 am
Share this topic:
Widescreen stages rendering incorrectly on 1.1
#1  October 05, 2019, 08:36:57 am
  • *
  • we live in a society
    • USA
    • www.8wayrun.com
I'm new to 1.1 and I'm facing some strange issues with widescreen stages. Some stages will work just fine, but a good number of them will either cut off the edges or look like this:



I've tried to do some digging on Google but all I can find is a recommendation to set the Stagefit parameter on mugen.cfg to 0... but there is no such parameter on mugen.cfg! At least not in the screenpack I'm using.
Re: Widescreen stages rendering incorrectly on 1.1
#2  October 06, 2019, 10:58:11 am
  • avatar
  • **
    • USA
You can just edit your Mugen.cfg to include the option.  You video cfg section should have these options.  (Don't just copy my values!)

Code:
;-------------------------------------------------------
[Video]
 ;The video resolution defaults to the same as the game resolution.
 ;You can force an alternate resolution by uncommenting the lines
 ;below.
Width  = 1920
Height = 1200

 ;Set to 1 to enable "safe" mode for older graphics cards.
 ;Many features will be disabled.
SafeMode = 0

 ;This is the color depth at which to run MUGEN.
 ;Only 16 is supported at this time.
Depth = 32

 ;Set to 1 to enable vertical retrace synchronization. Do not enable
 ;if BlitMode = PageFlip.
 ;Not supported in 1.0.
VRetrace = 0

 ;Set to 1 to enable fullscreen mode, 0 for windowed.
FullScreen = 0

 ;Set to 1 to make the window resizable when in windowed mode.
 ;Only supported for RenderMode=OpenGL and OpenGLScreen.
Resizable = 1

 ;Set to 0 to stretch the video to fit the whole window.
 ;Set to 1 to keep a fixed aspect ratio.
KeepAspect = 1

 ;Drawing mode
 ;Choose from Normal (fast) and PageFlip (less image "tearing")
;BlitMode = Normal
BlitMode = Pageflip

 ;Stage fit mode.
 ;0 - stage drawn to width of screen (may crop stages with tall aspect)
 ;1 - stage shrunk to fit into screen
 ;Ignored if RenderMode=System (forced to 0)
StageFit = 1

 ;System fit mode.
 ;0 - system drawn to width of screen (may crop motifs with tall aspect)
 ;1 - system shrunk to fit into screen
 ;Ignored if RenderMode=System (forced to 0)
SystemFit = 1

 ;Screen rendering mode.
 ;System - default SDL rendering mode (e.g. windib in Windows)
 ;DirectX - DirectX 5 renderer
 ;OpenGLScreen - hack that allows window resizing but could be slow
;RenderMode = OpenGLScreen
;RenderMode = DirectX
;RenderMode = OpenGL
;RenderMode = System
RenderMode = OpenGL
Re: Widescreen stages rendering incorrectly on 1.1
#3  October 06, 2019, 06:40:55 pm
  • *
  • we live in a society
    • USA
    • www.8wayrun.com
Oh, that did the trick. Not sure why it wasn't there in the first place but it works fine now. StageFit=0.

Thanks.
Re: Widescreen stages rendering incorrectly on 1.1
#4  October 09, 2019, 07:34:28 am
  • ***
    • beterwork-us.hopto.org
Oh, that did the trick. Not sure why it wasn't there in the first place but it works fine now. StageFit=0.

Thanks.
stagefit should be 1
you mugen game resolution should be 1280x760 not 640x480

video resolution should be ignored (commented)

you can try my prev-configed mugen with all native 16:9 stages (not forced widescreen will cause cut)
http://mugenguild.com/forum/msg.2447082



What does it mean for statefit = 0
if the game resolution ratio is not fit with the stage resolution ratio, cut the stage not show some part of it to maintain game resolution.
What does it mean for statefit = 1
if the game resolution ratio is not fit with the stage resolution ratio display full stage but add black bar to it to maintain correct stage ratio.
My MUGEN Website ==> for All my Characters Stages and Articles
https://beterwork-us.hopto.org
Last Edit: October 09, 2019, 07:38:39 am by beterhans
Re: Widescreen stages rendering incorrectly on 1.1
#5  October 09, 2019, 07:52:08 am
  • avatar
  • **
    • USA
Video resolution is actually a very helpful setting on Mugen 1.1.  You can use hardware scaling to produce a very crisp image on any monitor resolution.  I have my gameheight/width at 1920x1440 (640x480 300%) and scale it down to my monitor's 1920x1200.  This is much better than what was possible on Mugen 1.0.
Re: Widescreen stages rendering incorrectly on 1.1
#6  October 09, 2019, 09:05:57 am
  • ***
    • beterwork-us.hopto.org
Video resolution is actually a very helpful setting on Mugen 1.1.  You can use hardware scaling to produce a very crisp image on any monitor resolution.  I have my gameheight/width at 1920x1440 (640x480 300%) and scale it down to my monitor's 1920x1200.  This is much better than what was possible on Mugen 1.0.

this will scratch your sprite I guess everything will be pressed down.
My MUGEN Website ==> for All my Characters Stages and Articles
https://beterwork-us.hopto.org