YesNoOk
avatar

Reshade causing crashes now (Read 11445 times)

Started by Yui, February 09, 2018, 08:38:38 pm
Share this topic:

Yui

Reshade causing crashes now
#1  February 09, 2018, 08:38:38 pm
  • ***
  • ❤ The Graphical Enthusiast ❤
    • Japan
So this never happened before, but now whenever i try to start Mugen 1.1 with reshade, it crashes. I have not changed anything. I uninstalled it from my mugen and tried reinstalling it with the newest version 3.1.1 as opposed to 3.1.0, as i read that it fixes it, doesn't.

So was wondering if any else has this issue, and if so did you fix it? How?

Oh and it crashes on startup, not CTD but Mugen errors.

Code:
Error detected.


Clipboard tail:
---------------------------------------------------
M.U.G.E.N ver 1.1.0 Beta 1 P1 (2013.08.11) status log
---------------------------------------------------
Parsing command line...
Command line: G:\Mugen\1.Main Mugens\MUGEN HEX -  2nd BETA\mugen-x64.exe
Parse command line OK
Initializing...
Allocating game variables
Reading configuration file...Setting language "en".
OK
Initializing timer...performance timer enabled...frequency 3117780...OK
Initializing keyboard...configuring...OK
Initializing input engine...OK
Initializing sound...OK
Initializing BGM...  OK
Initializing graphics...gameCoord 1600x900...render mode 2_4...trying 1600x900x32 mode 0x0...failed.
Last Edit: March 15, 2018, 09:06:36 am by Chise
Re: Reshade causing crashes now
#2  February 10, 2018, 02:59:14 am
  • ***
  • The other Indian
    • India
Did you change the graphic settings of your graphics card in any way? What version of opengl do you have?
Re: Reshade causing crashes now
#3  February 10, 2018, 04:25:37 am
  • *
I'm new to reshade, but when I downloaded the newest version yesterday I had to do a few things for it to work. First, I noticed that my nvidia software seemed to be reset by a windows 10 update so that it no longer ran my mugen.exe using my graphics card but the integrated one on my laptop, so I had to reset that. Then, I may have been doing this wrong but it seemed like I had to launch the reshade setup app and select opengl (didn't work), then direct x 10/11+ or whatever and nothing happened, and then did the first directx option (reading left to right) and nothing happened and then went back to opengl (or directx 10/11+ again first) and it worked. I don't really know what I was doing and just kept trying hoping maybe at least one of the directx would work and the opengl finally worked.

My reshade is 3.1.0.230 and I have a 6 year old dell Inspiron laptop with nvidia  geforce gt 525m graphics card with a tiny amount of memory. Seems like you have a graphics card as well since it used to work for you (too bad it doesn't work on integrated cards, which is my main laptop) so I'm hopeful that it should work.

Hope this helps a bit.

P.S. @YugaCurry, thanks for pointing to reshade awhile ago. Totally changed my experience of Mugen and I enjoy it so much more with my kids now that it looks like it would have back in the day when the original sprites were made. Grateful!

Yui

Re: Reshade causing crashes now
#4  February 11, 2018, 12:22:19 am
  • ***
  • ❤ The Graphical Enthusiast ❤
    • Japan
Did you change the graphic settings of your graphics card in any way? What version of opengl do you have?

I didn't. I did a re-install of my OS a few weeks ago, but mugen was still working perfectly fine when it finished. So it can't be that.

My GPU's driver is fully updated, so idk what the issue can be. I didn't change any settings. As for my OpenGL version...where do i check that?

I'm new to reshade, but when I downloaded the newest version yesterday I had to do a few things for it to work. First, I noticed that my nvidia software seemed to be reset by a windows 10 update so that it no longer ran my mugen.exe using my graphics card but the integrated one on my laptop, so I had to reset that. Then, I may have been doing this wrong but it seemed like I had to launch the reshade setup app and select opengl (didn't work), then direct x 10/11+ or whatever and nothing happened, and then did the first directx option (reading left to right) and nothing happened and then went back to opengl (or directx 10/11+ again first) and it worked. I don't really know what I was doing and just kept trying hoping maybe at least one of the directx would work and the opengl finally worked.

My reshade is 3.1.0.230 and I have a 6 year old dell Inspiron laptop with nvidia  geforce gt 525m graphics card with a tiny amount of memory. Seems like you have a graphics card as well since it used to work for you (too bad it doesn't work on integrated cards, which is my main laptop) so I'm hopeful that it should work.

Hope this helps a bit.

P.S. @YugaCurry, thanks for pointing to reshade awhile ago. Totally changed my experience of Mugen and I enjoy it so much more with my kids now that it looks like it would have back in the day when the original sprites were made. Grateful!

I see, it installed properly the first time, however i have no idea if Mugen is using my GPU or my Integrated Card. I had no idea there was a setting or option for that. Where do i go to check that?
Re: Reshade causing crashes now
#5  February 11, 2018, 04:19:38 am
  • *
Yes, I didn't realize that laptops don't always use their graphics cards automatically for every appropriate application. Sometimes you have to tell them to recognize an app and default to them vs the graphics card. On my laptop the nvidia icon is in the context area on the lower right hand of my screen. I have windows 10 and click on the carrot sign or up arrow to view several other hidden icons and one of them is "nvidia settings". You might have something comparable with a different graphics card. If you have nvidia and it's not there, maybe search "nvidia settings" or google how to pull it up for your card. When I double click that icon the nvidia control panel opens up and under manage 3d settings (highlighted by default) I click on the program settings (vs. global settings) to pick which program I want to tell nvidia to execute vs. the integrated graphics. There's an add button, which brings up an add window and I choose browse and search for the mugen exectuable file and click on open. With that done (labeled as 1.) I move on to 2. which is to select the preferred graphics processor for the program and select nvidia vs. integrated. Then I hit the apply button at the bottom and I'm set.

I have a few different versions of mugen so I have to remember to do this for all of them. I also sometimes forget to hit apply and wonder why it's not working. Anyway, not sure if any of this is helpful, but hope it somewhat is.

Yui

Re: Reshade causing crashes now
#6  February 11, 2018, 05:23:17 am
  • ***
  • ❤ The Graphical Enthusiast ❤
    • Japan
Yes, I didn't realize that laptops don't always use their graphics cards automatically for every appropriate application. Sometimes you have to tell them to recognize an app and default to them vs the graphics card. On my laptop the nvidia icon is in the context area on the lower right hand of my screen. I have windows 10 and click on the carrot sign or up arrow to view several other hidden icons and one of them is "nvidia settings". You might have something comparable with a different graphics card. If you have nvidia and it's not there, maybe search "nvidia settings" or google how to pull it up for your card. When I double click that icon the nvidia control panel opens up and under manage 3d settings (highlighted by default) I click on the program settings (vs. global settings) to pick which program I want to tell nvidia to execute vs. the integrated graphics. There's an add button, which brings up an add window and I choose browse and search for the mugen exectuable file and click on open. With that done (labeled as 1.) I move on to 2. which is to select the preferred graphics processor for the program and select nvidia vs. integrated. Then I hit the apply button at the bottom and I'm set.

I have a few different versions of mugen so I have to remember to do this for all of them. I also sometimes forget to hit apply and wonder why it's not working. Anyway, not sure if any of this is helpful, but hope it somewhat is.

Alright i tried that, set it to my Nvidia GPU, still crashes when launching with Reshade :(

And yeah, i hit apply.
Re: Reshade causing crashes now
#7  February 11, 2018, 06:08:35 am
  • *
Here's how i approached it. First I wanted to get mugen working again, even without reshade/sweetfx. Did you get mugen to work once you uninstalled reshade/sweetfx? If not, then maybe there's some remnant of the previous version still there mucking things up. I was originally just going to copy all my chars/stages/etc. to a new mugen 1.1 download and start from scratch but once I realized I might be able to avoid all that by deleting the reshade/sweetfx files, that saved me a ton of time.

Step 2 was either to download and install reshade or get nvidia to default start mugen vs integrated. Tired so can't remember which came first. I wasn't very methodical my first go around. :/

Step 3 was what I didn't do in step 2.

Somewhere in there I kept launching reshade and picking directx options when opengl didn't seem to work. the directx options would launch but reshade was not working, there wasn't that intro to reshade text at the top of the screen that says reshade is working. So then I'd try the other directx option and then, when I got the same no reshade start, I went back to opengl option.

But I am wondering if you got mugen to work after uninstalling reshade/sweetfx first. Sorry to ask all these potentially basic questions, just want to make sure we're not missing anything here.

Yui

Re: Reshade causing crashes now
#8  February 11, 2018, 07:14:34 am
  • ***
  • ❤ The Graphical Enthusiast ❤
    • Japan
Here's how i approached it. First I wanted to get mugen working again, even without reshade/sweetfx. Did you get mugen to work once you uninstalled reshade/sweetfx? If not, then maybe there's some remnant of the previous version still there mucking things up. I was originally just going to copy all my chars/stages/etc. to a new mugen 1.1 download and start from scratch but once I realized I might be able to avoid all that by deleting the reshade/sweetfx files, that saved me a ton of time.

Step 2 was either to download and install reshade or get nvidia to default start mugen vs integrated. Tired so can't remember which came first. I wasn't very methodical my first go around. :/

Step 3 was what I didn't do in step 2.

Somewhere in there I kept launching reshade and picking directx options when opengl didn't seem to work. the directx options would launch but reshade was not working, there wasn't that intro to reshade text at the top of the screen that says reshade is working. So then I'd try the other directx option and then, when I got the same no reshade start, I went back to opengl option.

But I am wondering if you got mugen to work after uninstalling reshade/sweetfx first. Sorry to ask all these potentially basic questions, just want to make sure we're not missing anything here.

Mugen works 100% fine without reshade, no issues. I used to be able to run it no issues with reshade its just not working all of a sudden.

ExL

Re: Reshade causing crashes now
#9  February 11, 2018, 07:40:48 am
  • **
  • 1-800-SUICIDE
Can you please write about your issue on reshade forum?
People there might be able to help you, they are more knowledgeable about reshade's behaviour. I may be wrong, but to me it looks like there's something going on in mugen while reshade is locking screen and that prevent mugen from doing it's stuff... Not sure, though.
"Where greyness prevails, the black always take the power." (c) "Its Hard to be God" - brothers Strugatskie.

Yui

Re: Reshade causing crashes now
#10  March 08, 2018, 09:46:16 pm
  • ***
  • ❤ The Graphical Enthusiast ❤
    • Japan
Re-bumping this thread up because this is still unresolved. The Reshade forums were no help as nobody bothered to even respond to my thread.

This is really annoying. My GPU driver is fully updated, Mugen in my Nvidia Control Panel is set to use my GTX 960, and OpenGL is updated afaik. So idk wtf this issue is.

Reshade works in any other game but now it just hates mugen for some reason, even though i changed NOTHING in the mugen settings.
Re: Reshade causing crashes now
#11  March 08, 2018, 10:25:51 pm
  • **

Yui

Re: Reshade causing crashes now
#12  March 08, 2018, 10:46:02 pm
  • ***
  • ❤ The Graphical Enthusiast ❤
    • Japan
some people had a similar issue after some recent windows 10 update (mugen.exe was popping the same error u posted)
to fix this u get a clear mugen .. put your  stuff on it .. or add reshade and try im pretty sure its gonna solve it :D

clear mugen links  http://mugenguild.com/forum/topics/download-mugen-latest-release-1-1-official-release-8613-105841.0.html
sidenote : i had a cool setup with reshade and suddenly it stopped working didnt change a thing so it was that win 10 update

So i just tried that, downloaded a fresh 1.1 mugen, installed reshade, and im still crashing :(
Re: Reshade causing crashes now
#13  March 15, 2018, 03:54:10 am
  • *
I've had that exact issue.Heres I fixed it.I left my old Reshade installed.I download the new Reshade from the website.I put the installer in the folder where mugen.exe is.I selected Mugen with the installer.It says installing but it isn't since  I think that's a bug with it.So for this part, I clicked DirectX 10+ right next to OpenGL.A pop will say"Do you wish to download a collection of standard effects?"Click yes.Once downloaded it will show the list of effects that Reshade uses.Click Ok.That solved the problem for me.I hope that helps.

Yui

Re: Reshade causing crashes now
#14  March 15, 2018, 08:54:36 am
  • ***
  • ❤ The Graphical Enthusiast ❤
    • Japan
I've had that exact issue.Heres I fixed it.I left my old Reshade installed.I download the new Reshade from the website.I put the installer in the folder where mugen.exe is.I selected Mugen with the installer.It says installing but it isn't since  I think that's a bug with it.So for this part, I clicked DirectX 10+ right next to OpenGL.A pop will say"Do you wish to download a collection of standard effects?"Click yes.Once downloaded it will show the list of effects that Reshade uses.Click Ok.That solved the problem for me.I hope that helps.

Oh my god...THAT WORKED!!! THANK YOU!!! Your a Lifesaver!! <3

Just a quick note, you can replace your old Opengl32.dll's with the newest Opengl32.dll's from Reshade 3.1.2.250 (the newest version) after you do the Reshade DirectX10 thing. It will update your reshade to the newest version so u get all the fixes and enhancements.
Last Edit: March 15, 2018, 09:00:52 am by Chise