YesNoOk
avatar

[Tutorial] DXGL for Mugen 1.0 and 1.1 (Read 2355 times)

Started by Bullfrog, August 26, 2018, 07:22:21 pm
Share this topic:
[Tutorial] DXGL for Mugen 1.0 and 1.1
#1  August 26, 2018, 07:22:21 pm
  • **
    • Brazil
Hello,

Since one of those "big update" for Windows 10, that occurred months ago, I started having a peculiar problem with Mugen 1.0/1.1 running 4:3 resolutions (eg.: 640x480). From that update onward, any screenpack with the cited resolution would result in a "zoomed in" screen - cropping the top and button of the game outside the visible monitor area - when entering fullscreen mode.

Changing the properties of the mugen.exe, such as compatibility mode, force 640x480 resolution, etc, wouldn't change a thing.

I suspect that this issue has something about my monitor native resolution of 2560x1080 (21:9) + the Win10 update, because I haven't seen anyone else talking about this issue.


Ok, fast forward to the present, I have found a solution to my problem and I want to share it, mainly because, aside from fixing the resolution problem, I believe this might help to improve Mugen stability in general, but of course, much more testing is required before taking it as granted, so please leave feedback in case u try it.


The solution is called DXGL, an open source dll wrapper that aims to replace the Windows old ddraw.dll library.
I will quote from the official site:
Spoiler, click to toggle visibilty

So, let's get started:

First, BACKUP your stuff!!! Better safe than sorry

Second, go to your mugen/data folder, open mugen.cfg and set the RenderMode to OpenGLScreen (if mugen 1.0) or to OpenGL (if 1.1; although OpenGLScreen also works with mugen 1.1, I believe it's better to use OpenGL)


Third, go to the official DXGL site and download and install the latest version:
https://www.dxgl.info/downloads/

Now, run the "Configure DXGL" executable and then:



1 - Click on "Add" and add your mugen.exe

2 - Choose "Aspect Corrected Strech" from the Video Mode drop down menu

Hit "Apply" and u can already check, a "ddraw.dll" should appear alongside your mugen.exe and the resolution should already be working!


But now, there's still one more thing to do!
By default, all your options should be saved within the Windows registry, but you'll probably want to save your configuration locally, so it become portable and sharable.

So, click on the Advanced tab:

And click "Write ini file..." (use the default options)
Now, a "dxgl.ini" should be created in your mugen folder, alongside the mugen.exe and the ddraw.dll


And that's it! Currently I don't have much time to test it, but I was able to run Mugen 1.1 in Windows 10 w/o experience any crashes or anything else, but please leave feedback regarding this, in case u also test it

It's also worth mentioning, that the latest version of ReShade should work just fine if u use the DXGL dll, just make sure to choose OpenGL when installing ReShade.


Cheers!




Re: [Tutorial] DXGL for Mugen 1.0 and 1.1
#2  August 26, 2018, 10:02:04 pm
  • ****
  • The True Form of Chaos
    • mugekofe.web44.net/
Hey Bullfrog!! Nice find! I installed it right away. I did notice the reduced occurrences of crashes. I was using OpenGL and mugen 1.1. My game still did ultimately crash, but it feels more stable than before. I have slightly higher resolution than normal and I also notice it was still doing some clipping on my TV (but that's my TV's fault).  I didn't try it with reShade yet. Will let you know more if I find anything. The important thing is that mugen isn't broken after the install and none of the characters are contaminated either.
Official KOFE website is up.  Go visit it for all your KOFE needs:

http://mugekofe.web44.net/
Re: [Tutorial] DXGL for Mugen 1.0 and 1.1
#3  August 27, 2018, 02:10:24 am
  • **
    • Brazil
Hi SG, nice! really good news that u found less occurrences of crashes!!!  :yuno: :yuno: :yuno:


Since u mentioned playing on TV, let me share some off-topic knowledge that I just discovered recently (after buying a SteamLink and noticing a huge input lag).
The thing is: When u select the "source" of the image, on your TV, there's should be an option letting u choose the "name" or "type" of device that u are using. Make sure to use this option and set HDMI to "PC" or "Games".
I used to think that it was just "cosmetic", but it actually disables all the post-processing from the TV, reducing a lot the input lag, it's really a night and day of difference.
(not sure if it will help with the clipping, though)
Re: [Tutorial] DXGL for Mugen 1.0 and 1.1
#4  September 27, 2018, 04:09:48 pm
  • **
    • Brazil
Hey fant4smas, I'm glad it worked for u, mate!


(just an observation, it seems that u have installed DXGL inside Mugen's folder.
But u can install it with the default path ‪"C:\Program Files (x86)\DXGL" and just leave the "ddraw.dll" and "dxgl.ini" inside mugen's folder, to reduce clutter, ;) )
Re: [Tutorial] DXGL for Mugen 1.0 and 1.1
#5  September 28, 2018, 05:32:16 pm
  • avatar
  • ***
  • ̢̻̮̫̬̹̞̼̲̪̜̭͇̲͒ͪ̌ͬ̒̄̔̐͘͟ͅ ̢̋ͬ̓͗̏̇̌̑͐ͤ͗̔̊̕͏̴̣͎̟͈̬͚
    • Monaco
http://signavatar.com/32255_s.gif

please visit my request thread. here
bad grammar is art
Re: [Tutorial] DXGL for Mugen 1.0 and 1.1
#6  September 28, 2018, 06:28:17 pm
  • avatar
  • **
    • USA
I tried this out on Server 2k3 and Windows 7 and it really is working, although I'm not entirely sure why.  Mugen 1.1 in OpenGL mode shouldn't be using ddraw.dll for any reason that I can think of, but there's a barely discernible performance increase of maybe 2% (~39 v ~38 fps in controlled test).  This also seems to fix a glitch that can happen when playing against the Streets of Rage minigame where hitsparks start disappearing and it gets all weird.

This doesn't have any effect on the graphics output, so any changes made in DXGL won't do anything special as that part is being handled by OpenGL in a different thread.