YesNoOk
avatar

How to make AI jump less? (Read 234 times)

Started by Kolossoni, December 25, 2018, 10:02:22 pm
Share this topic:
How to make AI jump less?
#1  December 25, 2018, 10:02:22 pm
  • The Awakened
  • Interesting... Wanna Try?
    • South Korea
An AI-controlled char seems to jump whenever he/she feels like it.

I looked at the AI coding and made sure that the probability becomes less than 5% to cause jumps.

However, it seems that the jumps keep happening?
Is it hard-wired in MUGEN to allow constant random jumps once in a while?
PLS HELP!
Re: How to make AI jump less?
#2  December 25, 2018, 10:40:27 pm
  • ******
  • Legendary XIII
  • I am the eye of the storm to come!
    • New Zealand
    • network.mugenguild.com/cyanide/
Unless you hard code everything into the ai. Mugens ai will happily jump walk run etc for you. If you have done that already then you need to make your triggers tighter so 5% is only an option during a really specific situation. Otherwise 5% over 20 ticks can be considered 100%


In M.U.G.E.N there is no magic button

They say a little knowledge is a dangerous thing, but it's not one half so bad as a lot of ignorance.

2OS

Re: How to make AI jump less?
#3  December 25, 2018, 10:57:14 pm
  • ****
  • 608 Wannabe
  • Ich schicke dich zur HOELLE!! STIRB DU FEIGLING!!
    • Egypt
    • deuceovspadez.webs.com/
override statedef 40 to instantly selfstate to statedef 0 if ailevel.

if you want the ai to jump specifically (during running for example), define those conditions under that same selfstate.

you're also gonna want to omit "anim" underneath "statedef 40" and define it as a changeanim underneath that selfstate.
Re: How to make AI jump less?
#4  December 27, 2018, 05:05:42 am
  • ***
    • China
    • beterhans.blogspot.com/
thats not AI

when mugen system "AI" controls character
it just smash buttons no intellgenance at all.


normally you can pervent "system AI" goes into
human control state like
0 20 40

redirect or rewrite with your own state your own "AI"