YesNoOk
avatar

I think I've found a big Phantom Code bug....Am I going Crazy???!!! (Read 439 times)

Started by junkerde, February 27, 2019, 03:40:23 am
Share this topic:
I think I've found a big Phantom Code bug....Am I going Crazy???!!!
New #1  February 27, 2019, 03:40:23 am
  • avatar
  • **

  • Online
I don't know if this has to do with Mugen, or Fighter Factory, but I can consistently replicate this, with ANY character of my choosing. Basically, when I'm editing a character in fighter factory, and I UNDO and re-save to a previous state of the file I've had, it breaks the code for good.

I'm thinking fighter factory or something is leaving traces of "phantom code" of my previous edits. This video will explain and show it better, yes its using IKEMEN, BUT I've replicated this on Mugen 1.1 as well:


Am I missing something here? This has happened to me before and I posted about it, I was mugen 1.1 as well, here is a post about it:
http://mugenguild.com/forum/msg.2432272

I have a LIVESTREAM video of me coding these characters, and them working. Then the next moment, with the same piece of code, the characters COMPLETELY breaking their function. I'm just happy I was live streaming and recorded this new one as well. Am I going crazy????? It can't be my computer. It can't be the character, because this happens on others as well. Can't be just Ikemen, because it happens in Mugen 1.1 like above.

Thoughts? Did I miss something in the video? Is fighter factory leaving phantom code? Is mugen doing something weird with the character? I can reproduce it again if needed.

Last Edit: April 19, 2019, 12:18:23 am by junkerde
Re: I think I've found a big Phantom Code bug....Am I going Crazy???!!!
#2  February 27, 2019, 04:47:17 am
  • *****
  • Glorious Bastard
  • Halfway between both negatives
    • UK
    • plasmoidthunder.neocities.org
It looks as though you're using Fighter Factory Studio, so have you tested this with an older version of Fighter Factory to see if the same thing still occurs?
3DS FC: 0516 - 7483 - 3564
Oh, I want a diagram. I fucking love diagrams.
Re: I think I've found a big Phantom Code bug....Am I going Crazy???!!!
#3  February 27, 2019, 04:52:58 am
  • avatar
  • **

  • Online
I think I'll try downgrading to another version for now to see what happens for the next few days, I'll report back. It's really weird,
Re: I think I've found a big Phantom Code bug....Am I going Crazy???!!!
#4  February 28, 2019, 08:53:09 am
  • *****
  • Shame on you!
    • USA
FFS is known to have a few issues. Same with FF3, but not 1/4 as much.
vVv Wheat Stage Released vVv
Re: I think I've found a big Phantom Code bug....Am I going Crazy???!!!
#5  March 06, 2019, 09:47:24 pm
  • ******
  • B. is for Basara, of course
  • For 16 years, the one and only Basara-kun!!
    • Chile
    • network.mugenguild.com/basara/
I see you should check your code via notepad instead using FF since it's possible the previous codes weren't deleted after your changes and make trouble with your character. Try to open using notepad, fix the things you've to do and then try again