YesNoOk
avatar

Background Problem in FF3 (Read 22241 times)

Started by Joacs, May 11, 2018, 04:40:33 pm
Share this topic:
Background Problem in FF3
#1  May 11, 2018, 04:40:33 pm
    • Philippines
So I unpacked my sprite sheet, removed the background and made them 256 colors. Now I load them to Fighter Factory 3 and there were no problems. I saved it and then I Opened it the other day and all the sprites had black background.  Its kinda strange since I loaded kfm and he's sprites had black background as well.  I really need help for these, I cant start anything with this problem. I searched for tutorials and stuff but none fixed my problem.

Re: Background Problem in FF3
#2  May 12, 2018, 06:07:04 am
  • *****
  • Shame on you!
    • USA

  • Online
Maybe a simple thing you missed, but is show background color checked in sprites?
Also, you may want to see if the black color is the top left color. You'd only have to adjust the Alpha level of it and it'd be invisible. Set it to 0.
vVv Wheat Stage Released vVv
Re: Background Problem in FF3
#3  May 12, 2018, 01:30:05 pm
    • Philippines
I cant find any show background color in sprites but the show transparency color is checked, unchecking it does nothing. The transparent color is the one on my 0,0,0 and switching it with the black just messes up the sprite.
Re: Background Problem in FF3
#4  May 13, 2018, 08:32:43 am
  • *****
  • Shame on you!
    • USA

  • Online
I'm not sure what you mean by, "the one on my 0,0,0". It needs to be the first color in the palette. It's alpha needs to be 0.
If it's not the first color, move it to be the first color and save the palette as a new number.
Then import the sprite and use force palette and use the new number.
vVv Wheat Stage Released vVv
Re: Background Problem in FF3
#5  May 14, 2018, 02:40:57 am
    • Philippines
What I mean is the Transparent Color thing is the first color in my palette. Is it suppose to be black as the first color? The sprites had no background already when imported to FF3 btw.