YesNoOk
avatar

Mugen fighting jam problem (Read 1322 times)

Started by thefranchise03, December 10, 2009, 11:16:21 pm
Share this topic:
Mugen fighting jam problem
#1  December 10, 2009, 11:16:21 pm
  • avatar
  • **
my mugen fighting jam intro, logo, credits and game over screen doesn't show for some reason. I checked the system.def and everything seems right. Here is the intro.def

[SceneDef]
spr = data/OP.sff
startscene = 1


;-----------------------------------------------------------------
[Scene 0]
;Screen color
clearcolor = 0,0,0
;Overlay Anims (from 0 to 9)
layerall.pos = 0,0
layer0.anim = 100
layer0.offset = 0,0
layer0.starttime = 0
;Music
;bgm = LOAD.mp3
;bgm.loop = 0
end.time = 100

;Background image
[Begin Action 100]
0,0,0,0,-1


;-----------------------------------------------------
[Scene 1]
;Screen color
clearcolor = 0,0,0
;Overlay Anims (from 0 to 9)
layerall.pos = 0,0
layer0.anim = 10
layer0.offset = 0,0
layer0.starttime = 0
;Music
bgm = sound/OP.mp3         ;OP.ogg
bgm.loop = 1
;End time
end.time = 146


here is the system.def

;----------------------------
[Info]
name = "Mugen Fighting Jam"      ;Name of motif
author = "Jet"                ;Motif author name

;----------------------------
[Files]
spr = data/system.sff             ;Filename of sprite data
snd = data/system.snd             ;Filename of sound data
logo.storyboard = data/LOGO.def ;Logo storyboard definition (optional)
intro.storyboard = data/OP.def  ;Intro storyboard definition (optional)
select = select.def          ;Character and stage selection list
fight = data/fight.def            ;Fight definition filename
font1 = font/7x9.fnt
font2 = font/7x7.fnt
font3 = font/15x19.fnt

;----------------------------
[Music]
title.bgm = sound/Title.mp3   ;sound/Title.ogg
title.bgm.loop = 1
select.bgm = sound/select.mp3   ;sound/Select.ogg
select.bgm.loop = 1
vs.bgm = sound/Vs.mp3      ;sound/Vs.ogg
vs.bgm.loop = 1
Re: Mugen fighting jam problem
#2  January 03, 2010, 07:43:47 am
  • ****
  • English fluency I am swear!
    • Canada
here is the system.def

;----------------------------
[Info]
name = "Mugen Fighting Jam"      ;Name of motif
author = "Jet"                ;Motif author name

;----------------------------
[Files]
spr = data/system.sff             ;Filename of sprite data
snd = data/system.snd             ;Filename of sound data
logo.storyboard = data/LOGO.def ;Logo storyboard definition (optional)
intro.storyboard = data/OP.def  ;Intro storyboard definition (optional)

select = select.def          ;Character and stage selection list
fight = data/fight.def            ;Fight definition filename
font1 = font/7x9.fnt
font2 = font/7x7.fnt
font3 = font/15x19.fnt

;----------------------------
[Music]
title.bgm = sound/Title.mp3   ;sound/Title.ogg
title.bgm.loop = 1
select.bgm = sound/select.mp3   ;sound/Select.ogg
select.bgm.loop = 1
vs.bgm = sound/Vs.mp3      ;sound/Vs.ogg
vs.bgm.loop = 1







1.get rid of data/ on the bolded areas, see if that helps.

2. check the mugenlog and check if theres some line that says "failed to load intro" or something like that.

If you have 2, it's probably some bug in the story boards.
Quote
And "Reality" is unveiled.
What did it want . . .
What did it see . . .
What did it hear . . .
What did it think . . .
What did it do . . .