YesNoOk
avatar

A better .snd file (Read 8063 times)

Started by Ðøð®hëñgë, September 09, 2005, 06:09:55 pm
Share this topic:
A better .snd file
#1  September 09, 2005, 06:09:55 pm
  • **
    • www.newwavemugen.net/~randomselect/doorhenge/
Nothing makes me sadder then when a creator makes an awesome character and mucks it up with a low quality .snd file. I read a tutorial somewhere on the internet for old quake modifications and I thought that it applies here as well.

Sometimes a creator wants to have a lower quality .snd - probably to save space on their server or to save memory in Mugen. However I loathe it when people downgrade their .wav's where they sound tinny and hollow. There's a better way.

First is the way I do it. With Winamp's 'Output', 'Disk Writer plug-in' just set the settings to the quality you want and play the file. It’ll then re-record it with a little scratchiness but it will sound better than doing it by hand. And you can use the equalizer when you re-record it too.

Sometimes with some sounds it'll not sound right when doing it this way, and you'll want to convert it by hand anyhow. One is by saving it as an 8bit wav; this'll make the .wav kind of scratchy. Another people should do anyway is to change to stereo file to a mono one, this'll cut the file size in half. In fact the only time when using a stereo file would be the exception of stereo wav music played at center mass 'abspan = 1' in mugen. The final way to save space is to downgrade the kHz.

First, if you want to downgrade a 44100 kHz wav to a 22050 kHz, you should remove the frequency ceiling so the .wav won't have unnecessary noise in it.

In Goldwave from the 'effects' menu, select 'filters' and then 'lowpass/highpass' put 11025 (half of 22050 kHz) in the 'cutoff frequency' box, keep the filter options at 'lowpass' and 'static'. Now set 'steepness' to 20 (all the way to the right). Click OK to apply the filter. Now you can resample the wav into 22050 kHz without having unnecessary noise.

One more thing. If your sound is not loud enough no one is going to be able to hear the sounds when music is playing. You’ll want the sound to be louder. One way is to use 'maximize' this'll turn the volume all the way up in the .wav without losing clarity. But sometimes this isn't enough; if you'll want to turn it up further, do this: click 'effects', 'dynamics', and 'soft clip' from the list of preset shapes at the bottom. Then use 'maximize', this'll turn up the volume by rounding off the decibels, so you can still have it at a reasonable quality.

Color Modifiers are fun aren't they Blackjack.