YesNoOk
avatar

Very strange problem with Enemy,command="..." (Read 3769 times)

Started by S., February 22, 2009, 06:07:20 pm
Share this topic:

S.

Very strange problem with Enemy,command="..."
#1  February 22, 2009, 06:07:20 pm
  • avatar
  • **
Prepare yourself for some  ???-ness.

In two different characters (KFM1 and KFM2), I added a "down" command :
[Command]
name = "down"
command = ~D
time = 1

To check the command, I added this DisplayToClipboard under the Statedef -2 :
[State -2, Display]
type=DisplayToClipboard
trigger1=1
text="Down1=%d Down2=%d"
params=(command="down"),(enemy,command="down")

Now here comes the funny part :
KFM1 vs. KFM1, (enemy,command="down") does work.
KFM2 vs. KFM2, (enemy,command="down") does work.

KFM1 vs. KFM2, (enemy,command="down") does not work.
KFM2 vs. KFM1, (enemy,command="down") does not work.



I just cannot figure out why and where/what I got wrong.
Re: Very strange problem with Enemy,command="..."
#2  February 22, 2009, 06:17:38 pm
  • avatar
  • ***
maybe try enemynear instead of enemy

S.

Re: Very strange problem with Enemy,command="..."
#3  February 22, 2009, 06:27:09 pm
  • avatar
  • **
I tried but nothing changed.
Thank you anyway. :-\
Re: Very strange problem with Enemy,command="..."
#4  February 22, 2009, 06:31:59 pm
  • avatar
  • ***
seems your right its like the code works when ysed against same character but not against a different character even tho they have same command. im gonna expermiment with command = x and see if the results are the same
Re: Very strange problem with Enemy,command="..."
#5  February 22, 2009, 06:35:31 pm
  • ******
  • I will absolve you of your original colors.
    • www.bluehitbox.com
It's too quick, use the default: command="holddown" instead.

Re: Very strange problem with Enemy,command="..."
#6  February 22, 2009, 06:43:02 pm
  • ******
    • Germany
    • valodim@stratum0.org
I can think of a few reasons for this from an engine coder's point of view..

Bottom line for the engine user: Don't mess with other chars' commands :P
Re: Very strange problem with Enemy,command="..."
#7  February 22, 2009, 06:48:06 pm
  • avatar
  • ***
rajaa even holddown doesnt work nor command ="x" bottom line is it wont detect another chars commands excpet itselfs thats why it works against mirror self.

im sure you can detect the enemy's command when they are a target but otherwise i dnt think so
Re: Very strange problem with Enemy,command="..."
#8  February 22, 2009, 06:48:58 pm
  • ******
  • I will absolve you of your original colors.
    • www.bluehitbox.com
Enemynear,command="holddown" worksworked, I tried it myself before i posted.
Last Edit: February 22, 2009, 06:58:15 pm by Rajaa
Re: Very strange problem with Enemy,command="..."
#9  February 22, 2009, 06:54:28 pm
  • avatar
  • ***
does it work against another opponent and not the same character

example: kfm vs ryu not kfm vs kfm

i have already experimented and it does not work against another opponent apart from yourself
Re: Very strange problem with Enemy,command="..."
#10  February 22, 2009, 06:55:51 pm
  • ******
  • I will absolve you of your original colors.
    • www.bluehitbox.com
Lol, it worked when I triggered My Lilith's helper with enemynear,command="holddown" when I went against P.o.t.S's Nakoruru but not when I faced Jesuszilla's zero. I'm confused now.  ???
Re: Very strange problem with Enemy,command="..."
#11  February 22, 2009, 06:59:34 pm
  • avatar
  • ***
it must be something to do with the cmd just not sure what
Re: Very strange problem with Enemy,command="..."
#12  February 22, 2009, 07:46:42 pm
  • ******
  • I will absolve you of your original colors.
    • www.bluehitbox.com
I quit, lol.

What Valodim said.
Re: Very strange problem with Enemy,command="..."
#13  February 22, 2009, 07:52:54 pm
  • ******
    • network.mugenguild.com/pots/
Hint: order.
Use anything you want from my works.  If you need to contact me use email, not private messages.
Re: Very strange problem with Enemy,command="..."
#14  February 22, 2009, 08:20:19 pm
  • avatar
  • ***
doesnt that mean you would have to modify all characters? a bit too mcuh work
Re: Very strange problem with Enemy,command="..."
#15  February 22, 2009, 10:01:04 pm
  • ******
    • network.mugenguild.com/pots/
I've done a fair variety of stuff for Mugen yet have never found myself wishing I could detect P2's commands at any given time (at the times you want to do it, custom states, it already works), so very much doubt that'd be worth it.
Use anything you want from my works.  If you need to contact me use email, not private messages.
Re: Very strange problem with Enemy,command="..."
#16  February 23, 2009, 12:03:42 am
  • ***
  • +1 to whoever added Godzilla to the main index.
I've done a fair variety of stuff for Mugen yet have never found myself wishing I could detect P2's commands at any given time (at the times you want to do it, custom states, it already works), so very much doubt that'd be worth it.

Checking the partner's command is useful, though. I hope this problem doesn't extend to that as well.
i think we should call it an "engine" so we don't look like total idiots because otherwise we'd be arguing about a "game" and that would be somehow "dumber" than arguing about an "engine" on the "internet" for countless hours

Iced said:
I for one, do not enjoy round corners!  :bigcry:
But they hurt much less when we accidentally hit them!  :S
Last Edit: February 23, 2009, 12:31:28 am by MirageAtoli
Re: Very strange problem with Enemy,command="..."
#17  February 23, 2009, 05:56:10 am
  • ******
  • [E]
    • Mexico
Ddi you add the command in the exact same position ? afaik, the name labels for commands are disragarded on parsing and the commands are numerically sorted instead.
Re: Very strange problem with Enemy,command="..."
#18  February 23, 2009, 03:19:20 pm
  • ******
  • Just a butcher on a mission.
    • www.justnopoint.com/lbends
Be reminded that when you check your opponent's command, it is relative to whatever the command is locally.
For example, if KFM1 has recovery set to x+y and KFM2's is set to y+z, enemy, command="recovery" on KFM1 will check if KFM2 is pressing x+y.
I know this isn't relevant to the current problem but it's useful to know.
Re: Very strange problem with Enemy,command="..."
#19  November 20, 2009, 01:19:16 pm
  • ****
  • WIP: SF4 CE
Sorry for the bump, but I was thinking... how about suggesting something to Elecbyte along these lines?

Now that they're back, we could ask for them for a solution to some of these issues.  8)

Whaddaya think?

Re: Very strange problem with Enemy,command="..."
#20  November 21, 2009, 02:53:12 am
  • avatar
  • ***
quite a good idea. could be useful in terms of AI i reckon