YesNoOk
avatar

Need help fixing ai error with Juano16's MK Characters (Read 1244 times)

Started by Supercar11, March 21, 2024, 02:00:05 am
Share this topic:
Need help fixing ai error with Juano16's MK Characters
New #1  March 21, 2024, 02:00:05 am
    • USA
(See very bottom for the solution)


(mugen 1.1)

How do i fix this error i keep getting whenever i select the character (or just the separate defs included with it) (i did fix it for soul ninja by installing a different version of it)

however. female ninja & cyborg ninja always crashes with a similar error.

Here's the kitana.def from the female ninja umk3 character:
Library error message: Died parsing ailevel

Error detected.

Trigger not valid for mugenversion of character: ailevel
Error parsing trigger1, 1
Error parsing [State -1 -- AI ---,=== ACCIONES AI ===]
Error in [Statedef -1]
Error in code\ninja.cmd:1109
Error loading chars/mortalkombat\FemaleNinjaUMK3\mileenaUMK3.def
Error while precaching
Trigger not valid for mugenversion of character: ailevel
Error parsing trigger1, 1
Error parsing [State -1 -- AI ---,=== ACCIONES AI ===]
Error in [Statedef -1]
Error in code\ninja.cmd:1109
Error loading chars/mortalkombat\FemaleNinjaUMK3\kitanaUMK3.def
Error while precaching
Trigger not valid for mugenversion of character: ailevel
Error parsing trigger1, 1
Error parsing [State -1 -- AI ---,=== ACCIONES AI ===]
Error in [Statedef -1]
Error in code\ninja.cmd:1109
Error loading chars/mortalkombat\FemaleNinjaUMK3\mileenaUMK3.def
Error while precaching
Trigger not valid for mugenversion of character: ailevel
Error parsing trigger1, 1
Error parsing [State -1 -- AI ---,=== ACCIONES AI ===]
Error in [Statedef -1]
Error in code\ninja.cmd:1109
Error loading chars/mortalkombat\FemaleNinjaUMK3\mileenaUMK3.def
Error loading p1

Clipboard tail:
  Loading BG...OK
Stage loaded OK
  Allocating helpers...OK
Match RNG seed: 342521304
Reset persist vars team 0
Reset persist vars team 1
Loading character chars/mortalkombat\FemaleNinjaUMK3\mileenaUMK3.def...
  Loading info...Info: Mileena UMK3 loading in pre-1.0 compatible mode
OK
  Loading cmd command set code\ninja.cmd...OK
  Loading cns code\ninja.cns...OK
  Loading cns code\helpers.cns...OK
  Loading cns code\specials.cns...OK
  Loading cns code\shaddap.cns...OK
  Loading cns code\hyper.cns...OK
  Loading cns code\fatsimul.cns...OK
  Loading cns code\common.cns...OK
  Loading cns code\bonus.cns...OK
  Loading cns id\mileena.cns...OK
  Loading cmd state entry code\ninja.cmd...Character mileenaUMK3.def failed to load



if anyone knows whats going on please let me know  :)

Here's the 2 i used that has this issue
https://www.mediafire.com/download/topa5aroja5sd42/FemaleNinjaUMK3_v1.5.rar
https://www.mediafire.com/download/u3fvbewa6xujb4a/cyborgninjaUMK3_v1.2.rar







Update:
Turns out all i needed to do was change the mugen version in the .def to 1.1
Last Edit: March 22, 2024, 09:38:03 pm by Supercar11