YesNoOk
avatar

"Failed to load SteamUI localization file" Could use a little help D: (Read 5644 times)

Started by Hyogo, September 09, 2012, 06:11:52 PM
Share this topic:
"Failed to load SteamUI localization file" Could use a little help D:
New #1  September 09, 2012, 06:11:52 PM
  • avatar
  • *****
  • Holy BRAP
    • UK
Before you say "HERP, GO CHECK THE OFFICIAL STEAM FOURMS AND LOOK FOR THE SOLUTION"

I have done that, plenty of times infact and all I get is the same answer "Delete ClientRegistry.blob and SteamUI.dll"


This thread is just to confirm in case anyone has had this problem before and has managed to fix it, because I keep getting the same error after deleting those files.

If it's important, this happens during where it says "Updating Steam..." then the error comes up about 20 seconds after that pops up

I do have a plan on how to fix it but I need a little assistance from someone, it will require them having to send me their "ClientRegistry.blob and SteamUI.dll" files
These are found in (C:)/Program Files/Steam; then just look for the names of the files copy them and pack them in a .rar or .zip file and sending me the link via private message.

Please PM me if you're able to help me with this, if that solution works then I'll put this topic as solved, otherwise if no luck happened I'll make sure to contact you saying all failed.

This only recently happened today, I have not done anything faulty or stupid with the settings yesterday as I was playing quite a lot of TF2.


      Posted: September 12, 2012, 04:39:19 PM
Resolved, seems to be a server problem with my Internet provider

Seems to have blocked out the Steam Servers along with various other games I play.
Last Edit: September 12, 2012, 04:44:26 PM by Hyōgo™