YesNoOk
avatar

Avoid stretching in full screen (WINmugen) (Read 735 times)

Started by Momotaro, September 28, 2021, 08:39:57 PM
Share this topic:
Avoid stretching in full screen (WINmugen)
#1  September 28, 2021, 08:39:57 PM
  • *****
  • A.K.A. NED
  • "Videl's Chapter" WIP manga (inking...)
I would like to put some old Winmugen game in full screen without having the deformation due to "stretching"

is there a suggestion how to configure it ?
(I use "DoubleRes = 4" to have some higher res lifebars correctly displayed)

Just in case.
Part of mugen cfg...
Code:
;-------------------------------------------------------
[Video Win]
 ;Enter the width and height of the resolution you want to set here.
 ;The optimal resolution is 320x240, but if your video card has problems
 ;You may want to try 640x480.
Width  = 640;780;640;320
Height = 480;495;480;240

 ;This is the color depth at which to run MUGEN. You should set it to
 ;16 bit color unless your video card has problems with it.
 ;16-fastest, 24,32-slower, 8-slowest/worst
Depth = 16

 ;Set this parameter to 0 to disable screen stretching, and set it to 1 if
 ;you want to scale it up to fit the current resolution.
Stretch = 1;0

 ;Set this parameter to use a resolution-doubling filter. You will
 ;need a fast machine to use these filters. You will need to increase
 ;the screen resolution to at least 640x480 for these modes.
 ;0 - off
 ;1 - diagonal edge detection
 ;2 - bilinear filtering
 ;3 - horizontal scanlines
DoubleRes = 4;0;4;0

 ;DirectX mode
 ;Choose from Hardware, Software, Windowed, Overlay, Safe and None
 ;Hardware and Software run in full-screen. Windowed and Overlay
 ;run in a window. The windowed modes require you to set Depth to
 ;whatever color depth you are using for you desktop. The best results
 ;are when you run in 16-bit color. There is no advantage to running
 ;in 32-bit color. If Hardware, Software and Windowed fail, try Safe.
 ;None uses GDI to draw, so it's very slow. Use None only if
 ;you cannot get anything else to work.
 ;Overlay is not supported by all video cards, but can be faster than
 ;Windowed if it works.
DXmode = Windowed;hardware;Windowed

 ;Set to 1 to enable vertical retrace synchronization. Do not enable
 ;if BlitMode = PageFlip.
VRetrace = 0

 ;Drawing mode
 ;Choose from Normal and PageFlip
BlitMode = PageFlip
Re: Avoid stretching in full screen (WINmugen)
#2  September 29, 2021, 02:06:01 AM
  • ******
  • Legendary XIII
  • I am the eye of the storm to come!
    • New Zealand
    • network.mugenguild.com/cyanide/
Set stretch to 0? It seems to be what you're after.


In M.U.G.E.N there is no magic button

They say a little knowledge is a dangerous thing, but it's not one half so bad as a lot of ignorance.
Re: Avoid stretching in full screen (WINmugen)
#3  September 29, 2021, 11:54:50 AM
  • *****
  • A.K.A. NED
  • "Videl's Chapter" WIP manga (inking...)
Set stretch to 0? It seems to be what you're after.

Thanks @Cyanide
This is what I tried before, but there is NO change when set to "0".
I don't understand why...

full screen display is still stretched...