YesNoOk
avatar

KO sound playing twice (Read 90 times)

Started by DS, May 14, 2021, 06:09:27 AM
Share this topic:

DS

KO sound playing twice
#1  May 14, 2021, 06:09:27 AM
  • ****
    • Brazil
    • deathscythemugen.neocities.org/
So I wanted my characters to stop moving as soon as the round is over, I went to my fight.def and changed "over.waitttime" to 0, but now the K.O sound is playing twice. Didn't happen before the change and I could not fix it myself (only reseting it to the value it was before) or find anything related searching the forum or on google. Any help is appreciated.

Edit:
I'll take the ride to ask something else. It's kinda related.
Is there any way to make the velocity of the characters "normal" after a KO? Because by default they will be sent flying faster than normal. I vaguely remember seeing somewhere a parameter to control the velocity of the characters after the KO, but now I can't find it.
Last Edit: May 14, 2021, 07:38:15 AM by DS
Re: KO sound playing twice
#2  May 14, 2021, 07:50:16 AM
  • ***
  • | The Awakened |
  • 하나뿐인 한국인 대표
    • South Korea
    • sites.google.com/view/kolossoni-mugen
The KO sound playing twice is an infamous glitch in MUGEN.
You'll need to make a custom trigger for your KO sound instead of relying on the system itself.

Regarding the second part of your question.
I've tried something like this for my KOF'96 characters (they fly high up in the sky with little X velocity).
I had to add VelSet into my 5030 state with alive = 0 as the trigger.

Try to mess around with your triggers and get back to us.