YesNoOk

Show content

This section allows you to browse the content for this member. Note that you can only see content for which you have sufficient viewing permissions.

***
VirtuallTek is Offline
Contact VirtuallTek:

VirtuallTek

Contributor

Messages by VirtuallTek

    

Re: Fighter Factory Studio 3.5.3 (UPDATED June, 16)

 June 26, 2018, 02:50:51 PM View in topic context
 Posted by VirtuallTek  in Fighter Factory Studio 3.5.3 (UPDATED June, 16) (Started by VirtuallTek April 04, 2018, 02:43:30 PM
 Board: Your Releases, 1.0+

Thanks guys! Checking these bugs.

Something little offtopic, but someone knows Fighter Factory Ultimate 4.3? There's a Japanese guy doubting me on another forum saying my domain was on sale last year and maybe someone could buy it to fake that's me, so Studio is fake and people shouldn't donate on Patreon. Very strange guy, I can't find this version in any place. He has good knowledge about code protection in Ultimate and license terms. I feel hes trying to sell FF somewhere.
    

Re: Fighter Factory Studio 3.5.3 (UPDATED June, 16)

 June 20, 2018, 03:28:40 PM View in topic context
 Posted by VirtuallTek  in Fighter Factory Studio 3.5.3 (UPDATED June, 16) (Started by VirtuallTek April 04, 2018, 02:43:30 PM
 Board: Your Releases, 1.0+

When I check for updates (in 3.5.3), I get a message (two days later, the bug is no longer observed):
This was an error in the XML on the server. This is why the error disappeared.

And there was another bug: now there is no zoom text in current animation editor. In code editor (animation) everything is fine.
What do you mean by zoom text?

I imported my configuration from 3.5.2 and I swapped Ctrl+S and Ctrl+Shift+S (honestly, they all should be the other way around since I rarely want to save all files at once), yet for some reason Ctrl+S doesn't save anything. I checked the macros menu and it's there so IDK what's happening.
The file was modified?
Because all save functions ignore unmodified files (no reason to save if nothing changed). But I'm checking the Save function to ensure it's working as expected.
The shortcut you talked about is on "Save all" because only the modified files will be saved, so it is best than save only the current file. If just current file was modified, it performs the same way.

There's just one thing that is preventing me from using it and not giving up on good ol' FF3
The non-indexed images still have a rendering problem, and at a friends' too, so i'd assume that's not on my end. welp
and since it wasn't correctled in the last 2 or 3 updates, i'm going to post it again, just in case

Spoiler, click to toggle visibilty
Wierdly enough, the same doesn't happen when the image is interpolated using the air editor.

Spoiler, click to toggle visibilty

Besides that i've not encountered any more bugs or things that prevent me from using it, so great job (y)
Ps: Oh and also the updater gave me an error (no update available!), so i had to download it manually, not that i mind it, just a heads up.
You're using 3.5.3? (seems you're still in 3.5.2, this time you must redownload, no update inside 3.5.2 updater)
Tested here with 32bit image I made, very similar to your sprite and it's displayed right. I changed the way it renders sprites with alpha channel in 3.5.3 to fix this. If the problem persists, maybe it's a problem with your OpenGL drivers, so try enabling Native painting engine in Options -> Image. Will be great if you can send this sprite to me.
And, currently, there's no update available for 3.5.3, it's not an error!

Just got a freeze and crash when deleting states.
Can't reproduce any way. trying to find something.

FFSX crashes when I click in the button "Replace All" for long char strings.
Also crashing when exporting sprites.
(I'm using Xubuntu BTW)
Can't reproduce on 3.5.3. Do you can post a sample string to test?
Can't reproduce too. This happens on any SFF? If not, send me one to test, maybe it's corrupted somewhere.



If people can support us on Patreon would be great, as this way I can put more time and effort to make more frequent updates.
Thanks!
    

Re: Fighter Factory Studio 3.5.3 (UPDATED June, 16)

 June 16, 2018, 08:15:27 PM View in topic context
 Posted by VirtuallTek  in Fighter Factory Studio 3.5.3 (UPDATED June, 16) (Started by VirtuallTek April 04, 2018, 02:43:30 PM
 Board: Your Releases, 1.0+

Version 3.5.3 released. Bugfix only. More details on Patreon.
    

Re: Fighter Factory Studio 3.5.2 (UPDATED May, 31)

 June 10, 2018, 01:01:53 AM View in topic context
 Posted by VirtuallTek  in Fighter Factory Studio 3.5.3 (UPDATED June, 16) (Started by VirtuallTek April 04, 2018, 02:43:30 PM
 Board: Your Releases, 1.0+

Not sure if this was mentioned already, if it was I apologize; I've decided to get into editing sprites with the Image Editor, but every time I use the copy and paste functions to copy parts over, then save a sprite I'm editing, trying to switch to another sprite afterward crashes the program. Seems to happen randomly so it may be a bit hard to reproduce.
Found the bug and fixed it, thanks!

Some sounds get cut off early when playing them on Mac.
Yes, this happens on Linux too. It's a well known issue since the first version. This is a Qt bug, so will be harder to fix without big changes, so I'm skipping this now.

I'm almost ready to release 3.5.3 with lots of bug fixes, but nothing new. This will fix the mess with the same version without auto update too.

Thanks!
    

Re: Fighter Factory Studio 3.5.2 (UPDATED May, 31)

 June 09, 2018, 02:10:26 PM View in topic context
 Posted by VirtuallTek  in Fighter Factory Studio 3.5.3 (UPDATED June, 16) (Started by VirtuallTek April 04, 2018, 02:43:30 PM
 Board: Your Releases, 1.0+

Hey, I just noticed that onionskin for a sprite disappears when I switch to the .AIR editor. I actually used to use that feature a lot for drawing CLSNs when I need just 1 or 2.
Seems people didn't noticed, but now, AIR editor has its own OnionSkin that uses anim/frame combo that's exactly what people are requesting :D. It's on the thumbnails panel on all presets.

EDIT: The 1-tick animation frame issue is still present. Also, it freezes when the timing is 0. In MUGEN, it simply skips to the next frame.

Also, I can't click multiple times to select a CLSN that's underneath another. Really makes attack placement a pain. I know this is a difficult case, but it's an important one. You already have a list of hitboxes, so what you can do is iterate through each one, keep track of the index in the array it's currently on, and move to the next that fills the criteria of the mouse clicking in its location.
OK, thanks!

I do have a question though. When I have more than 1 char open in FFS and I am on a certain sprite/anim in the sff or air and I go to another char tab. Then I go back to the previous char tab. It is rarely where I left it. I don't understand the logic it's using to save the location I was last looking at. So I have to find the sprite/anim again. Multiply that by 100 and it gets exasperating. Can you make it keep my location?
Yeah, this was only partially implemented. I will finish it now, thanks!

Hmmm... The program is not updated properly! Updated only: "update.exe" & some xml-files (update, config, history, shortcuts, engines\mugen\config). After that "update.exe" no longer runs. Tried to update other copy of the program (also, through the menu) - every time updates are downloaded, try to be established and nothing happens.

P.S. Checked by the time of the last file change and the absence of fixes of previous bugs)))  Operation system - Windows 7 x86.
The update only contains the executable, and two dynamic libraries, no way it will change xml files, except update.xml. But the update process has some bugs, mainly file permissions that break things on Unix systems. And if you run it as administrator on a folder with admin rights, update will fail.

I think will be better to fix these remaining bugs and add the suggestions above and release as 3.5.3 so people will redownload it and in the next updates we do it only by "Check updates".

Thnaks!
    

Re: Fighter Factory Studio 3.5.2 (UPDATED May, 31)

 June 06, 2018, 02:23:34 AM View in topic context
 Posted by VirtuallTek  in Fighter Factory Studio 3.5.3 (UPDATED June, 16) (Started by VirtuallTek April 04, 2018, 02:43:30 PM
 Board: Your Releases, 1.0+

- Little bug in Tools -> Options -> Image -> Center of zoom: unable to set value "Center of workspace" (sometimes this spontaneously changing the value of the "zoom mode") 

- The inability to add an mugen engine with a name other than "mugen.exe" (for example, when using the screenpack selector by Sludge it is required that it be called "winmugen.exe"). This is not a bug, but very unpleasant ((((

I liked the improved search - files in the code editor are marked at once, in which the search string are also found. Very convenient. Advanced search looks cool too)))) This has long been missing in Fighter Factory.
Fixed, thanks! Glad to see you liked the improvements.

Just got this weird bug where all the expanded menu items would display on my other monitor.

Also, crashes on loading empty .AIR file when switching to animations editor.

"New Animation with all" in AIR editor has the add dialog pop up twice.

EDIT: Animation player doesn't seem to like 1-tick animelems too well. It freezes up when it loops around and the first frame is 1 tick. I believe this is also an issue when the last frame is 1 tick.

I also had a few crashes this morning when using find/replace; not entirely sure what caused it.
Fixed the bugs: dialog pop up twice and animation player. The other ones I can't reproduce, but I'm trying to figure in what situation this can happen. Thanks!
    

Re: Fighter Factory Studio 3.5.2 (UPDATED May, 31)

 June 02, 2018, 05:33:52 PM View in topic context
 Posted by VirtuallTek  in Fighter Factory Studio 3.5.3 (UPDATED June, 16) (Started by VirtuallTek April 04, 2018, 02:43:30 PM
 Board: Your Releases, 1.0+

    

Re: Fighter Factory Studio 3.5.2 (UPDATED May, 31)

 June 01, 2018, 06:05:35 PM View in topic context
 Posted by VirtuallTek  in Fighter Factory Studio 3.5.3 (UPDATED June, 16) (Started by VirtuallTek April 04, 2018, 02:43:30 PM
 Board: Your Releases, 1.0+

There's a problem with CLSN defaults:

.AIR code:
Code:
; Crouching Light Punch
[Begin Action 400]
Clsn2Default: 3
  Clsn2[0] = 0, -58, 24, -38
  Clsn2[1] = -24, -52, 24, -32
  Clsn2[2] = -28, -32, 36, 0
400,0, 0,0, 3
Clsn1: 1
  Clsn1[0] = 33, -16, 67, 0
Clsn2: 3
  Clsn2[0] = 0, -58, 24, -38
  Clsn2[1] = -24, -52, 24, -32
  Clsn2[2] = -28, -32, 51, 0
400,1, 0,0, 3
400,0, 0,0, 4

Should be displaying that first CLSN for the final frame. CLSNDefaults in MUGEN are kept on any subsequent frames as long as they are not overridden by another CLSNDefault; they are independent of one another as well.
Fixed, thanks!
    

Re: Fighter Factory Studio 3.5.2 (UPDATED May, 31)

 June 01, 2018, 02:35:53 AM View in topic context
 Posted by VirtuallTek  in Fighter Factory Studio 3.5.3 (UPDATED June, 16) (Started by VirtuallTek April 04, 2018, 02:43:30 PM
 Board: Your Releases, 1.0+

Reuploaded the version 3.5.2 with all bug fixes. The change this time is big so a patch would be almost a full version.
Details on Patreon page.

Thanks!
    

Re: Fighter Factory Studio 3.5.2 (UPDATED May, 19 + PATCH)

 May 30, 2018, 05:34:38 PM View in topic context
 Posted by VirtuallTek  in Fighter Factory Studio 3.5.3 (UPDATED June, 16) (Started by VirtuallTek April 04, 2018, 02:43:30 PM
 Board: Your Releases, 1.0+

*EDIT* Ok I fixed the issue NEVER I mean Never put the program in the local C folder it doesn't like it. lol
Some folders require elevated access to be writable. The only way to run the program in such folders is running as administrator.

EDIT: Fixed the bugs. I'm testing the auto update system. After that, I'll release the update.

Thanks!
    

Re: Fighter Factory Studio 3.5.2 (UPDATED May, 19 + PATCH)

 May 29, 2018, 03:33:19 PM View in topic context
 Posted by VirtuallTek  in Fighter Factory Studio 3.5.3 (UPDATED June, 16) (Started by VirtuallTek April 04, 2018, 02:43:30 PM
 Board: Your Releases, 1.0+

Ok why wont it save my settings it even says this when I open it.
What is the directory do you put FFS in?

I'm finishing an auto update system that will help a lot, both me to release patches easely and for the users to download and install it. All bugs people reported are being fixed for the next update.

Thanks!
    

Re: Fighter Factory Studio 3.5.2 (UPDATED May, 19 + PATCH)

 May 26, 2018, 08:54:13 PM View in topic context
 Posted by VirtuallTek  in Fighter Factory Studio 3.5.3 (UPDATED June, 16) (Started by VirtuallTek April 04, 2018, 02:43:30 PM
 Board: Your Releases, 1.0+


What's the reason do you want more than one instance?


Because it is how I edit my mugen characters, it is easy for me to edit my characters since I work with hd characters and high resolution stages and I compare them with the low quality stage with which I believe, thus giving the same axes of the original so that I saved work and time, I would like to implement it if it is not right, likewise thanks for how it is done and how it was corrected is excellent ...
OK

What does the character's MUGEN version say in the .def?

I've tried with both Mugenversion = 1.1 and Mugenversion = 1.0     I get the same error.
It's related to my characters sharing a .cns file. I know this because if I delete the line "st4 = ../../Data/Mugen States.cns" on .Def (being that line the shared .cns), it works. However, I works anyway on Fighter factory 3.

Try to have two characters sharing a .cns file, I bet you will get the same error. I know nobody makes characters share .cns files but it is a really good way to make the build lighter, since all characters use a same group of sprites.

You're one of the first devs I've seen do that! Good on you for knowing to share data. I suspect FF just doesn't like relative paths in the .def for whatever reason.

EDIT: Also, it's erroring out on sinadd's third parameter (sinadd parameters are R,G,B):


EDIT2: For some reason, all keyboard shortcuts were cleared. I think this was done while importing settings on first boot. When I added back the code comment/uncomment shortcut and uncommented some code, this happened:

It's erroring out on sinadd's third parameter because it needs four: sinadd = ampl_r, ampl_g, ampl_b, period (int, int, int, int)
About the comment/uncomment, I'll check this. Thanks!

Crash program in the code editor when deleting code that contains the "[StateDef XXX]" (XXX is some number). Observed with any character (for example, Kung Fu Man).
This is the same bug Lurker reported. This happens when you delete the code of the item selected in the left panel's list. Fixed, thanks!

having a issue with the channel splinter. every time i code them and the split in the game instead of looking like the picture it become purple in the game isnt it suppose to act like stage tool? or am i doing something wrong or is the channel splinter a wip?
You need to mix all three channels. You're adding the Blue channel to the Red and missing the Green one, so it turns purple.

Hi VirtuallTek, good release so far.
but when i am doing a screenpack the project says Character not system screen also animation button causes to crash while pressing it (kills the app): 

hope you can fix those if you can.

cheers
DoomJoshuaBoy

P.S.
Sorry about my work: this is what im working on though.
OK, I'll take a look. Thanks!
    

Re: Fighter Factory Studio 3.5.2 (UPDATED May, 19 + PATCH)

 May 23, 2018, 03:52:38 PM View in topic context
 Posted by VirtuallTek  in Fighter Factory Studio 3.5.3 (UPDATED June, 16) (Started by VirtuallTek April 04, 2018, 02:43:30 PM
 Board: Your Releases, 1.0+

Hi,
Thanks for sharing your creation VirtualTek. I'd like to report a "situation". I don't know if it is the program's fault or mine, but here it goes.
I get the following error, which doesn't occur on FF3.

Error in ../../Data/Mugen States.cns:0
Character mugenversion is older than this version of M.U.G.E.N.
Error loading chars/ffs_0/ffs_0.def

I have a file shared among all characters; "Mugen States.cns", and my character has "mugenversion = 1.0" under [Info]

Thats really strange, why does it only happen in this FF version ? Any help? Please.
Can you send me this char?

If I try to delete or ctrl+x a code in the middle of a big file (more than 10k lines) the program freezes.
This in the current version (3.5.2)? This is like the bug in 3.5.1 I fixed in 3.5.2, can't reproduce in the latest build, tried cut and delete on many lines in a 20k lines file.

UPDATE: Reuploaded Windows and Linux versions with a patch to fix some small bugs. A patch only (files to replace) is on first post too.

Thanks!
I'm using the lastast build, I selected around 3000-5235+ lines and this happened again, maybe it's on my end?
Edit: For exemple, on vans' Kyo I select the line 5408 up to line 10643 try to cut and ff freezes.
If I try to select from the first line up to the end of the file I can cut and delete normally.
Ah, and if for some reason I have some code in the .def and try to load it as a state too I can't test the character.
OK, I'll test on this char, thanks!


Hello VirtuallTek is not an error but if part of it in the previous version is the 3.5.1 if I let it do it but not in this, what happens is that it does not let me open 2 programs at the same time with the same icon of the program, I repeat in the previous version if he left me, I would like it to be in this version, thank you.
What's the reason do you want more than one instance?

I just wanna say i love this new version, it's incredible!

All the issues i had have been resolved...cept 1. Idk if this is intentional or just the way it renders stuff...but is it normal that stuff like Outer Glows, Transparent Images and other color/glow based effects on images, look kinda...pixely? Idk if thats the right word...they look off...like their not truly PNG/Transparent.

This wasn't an issue in FF3. It's not a huge issue, it's just realy jarring. When it showed up like that i got REALLY Scared i did something wrong so i was messing around in photoshop for like 30 minutes trying to figure out what i did wrong :(

Note: Yes, Nine in both have SFF's at 1.1.
Can you send me this image?

Thanks!
    

Re: Fighter Factory Studio 3.5.2 (UPDATED May, 19 + PATCH)

 May 21, 2018, 01:55:14 PM View in topic context
 Posted by VirtuallTek  in Fighter Factory Studio 3.5.3 (UPDATED June, 16) (Started by VirtuallTek April 04, 2018, 02:43:30 PM
 Board: Your Releases, 1.0+

If you install a new version, use the Import button on welcome screen to grab your last installation configs, which includes history and all configs. The ffc just saves the main configs, not the engine specific ones. I'll change it later.
Thanks!
    

Re: Fighter Factory Studio 3.5.2 (UPDATED May, 19 + PATCH)

 May 21, 2018, 06:26:06 AM View in topic context
 Posted by VirtuallTek  in Fighter Factory Studio 3.5.3 (UPDATED June, 16) (Started by VirtuallTek April 04, 2018, 02:43:30 PM
 Board: Your Releases, 1.0+

If I try to delete or ctrl+x a code in the middle of a big file (more than 10k lines) the program freezes.
This in the current version (3.5.2)? This is like the bug in 3.5.1 I fixed in 3.5.2, can't reproduce in the latest build, tried cut and delete on many lines in a 20k lines file.

UPDATE: Reuploaded Windows and Linux versions with a patch to fix some small bugs. A patch only (files to replace) is on first post too.

Thanks!
    

Re: Fighter Factory Studio 3.5.2 (UPDATED May, 19)

 May 20, 2018, 06:24:04 PM View in topic context
 Posted by VirtuallTek  in Fighter Factory Studio 3.5.3 (UPDATED June, 16) (Started by VirtuallTek April 04, 2018, 02:43:30 PM
 Board: Your Releases, 1.0+

I found a new bug with the update. After quitting Fighter Factory Studio and reopening it again for later, the engines deleted themselves and will not save. Even if I save the settings in an ffc file and open it, the list will not appear and have to reconfigure it again. I know there won't be anymore public releases after this one, but can you please look at this? Because I can't play test characters like this if I have to keep adding an engine every time I open the program. This wasn't an issue with the 3.5.1 update, so I don't know how this happened.
I'll check this, but don't worry, I'm waiting some time for feedback and a patch will become available soon.

For some reason after a while, the Project and Edit menu items become highligtable, yet when I click them, the menu doesn't open. The rest work just fine.
Checking this, thanks JZ!

Known issues (already fixed, waiting more to release a patch):
- Some functions in the palettes menu are disabled (won't work)
- Advanced search freezes with empty string

Thanks!
    

Re: Fighter Factory Studio 3.5.2 (UPDATED May, 19)

 May 20, 2018, 04:34:12 AM View in topic context
 Posted by VirtuallTek  in Fighter Factory Studio 3.5.3 (UPDATED June, 16) (Started by VirtuallTek April 04, 2018, 02:43:30 PM
 Board: Your Releases, 1.0+

I'm still getting crashes when attempting to open the Open window with the 64 bit version. JZ has done a bit of troubleshooting with me and he's concluded that it's likely related to me running Windows 8.1.
Try one more thing: there's a new setting in Options window called "Use system native open dialog", disable it. If the problem persists, will be helpful if you can provide some crash dump. I'll try to get a Windows 8.1 PC to test.

Thanks!
    

Re: Fighter Factory Studio 3.5.2 (UPDATED May, 19)

 May 20, 2018, 01:02:04 AM View in topic context
 Posted by VirtuallTek  in Fighter Factory Studio 3.5.3 (UPDATED June, 16) (Started by VirtuallTek April 04, 2018, 02:43:30 PM
 Board: Your Releases, 1.0+

Version 3.5.2 released!
More details on Patreon post.

Thanks!
    

Re: Fighter Factory Studio 3.5.1 (UPDATED April, 07)

 May 06, 2018, 11:55:54 PM View in topic context
 Posted by VirtuallTek  in Fighter Factory Studio 3.5.3 (UPDATED June, 16) (Started by VirtuallTek April 04, 2018, 02:43:30 PM
 Board: Your Releases, 1.0+

Version 3.5.2 is almost done, it's so better now. I already addressed all most requested features and fixed a lot of bugs. FFS is getting very stable, and a good base to start the big new features.

But, again, to make this grow and implement huge new features I need your support on Patreon, as this way I can put more effort (time) on it.  After this version, I'll start to release private builds for our Patrons, so public releases are likely to be less frequent.

Thanks!
    

Re: Fighter Factory Studio 3.5.1 (UPDATED April, 07)

 May 02, 2018, 05:54:41 AM View in topic context
 Posted by VirtuallTek  in Fighter Factory Studio 3.5.3 (UPDATED June, 16) (Started by VirtuallTek April 04, 2018, 02:43:30 PM
 Board: Your Releases, 1.0+

Hi guys, I'll not answer one by one this time, but I'm trying to address all issues in the next version, so it will take some time to finish everything.
About sff, I already changed the save function so it complains only in the case of incompatible pixel formats and you can let FF fix them, all other errors are warnings now, so you can save without problems. The issues list was moved to a far better place, so you can check them and navigate easely. The syntax checking is being improved and a mass search & replace function will be available, so the polemic stuff can be fixed in a single click, but you can still ignore the errors and do what you want, not such drama. The empty project will be available and new capabilities are working right now as open single file, open from first argument (for command line or double-click). The new way it handle files in a project opens a lot of possibilities that will be explored further in the future. I'm fixing bugs too, of course.
As FFS is portable, I'm keeping config files inside its folder, and an "import from another installation" function will be added to solve the reconfiguration steps on fresh install of a new build. There's some problems with unicode on file system that breaks some functions, so I'm addressing this too.
About the pink pixels, the resizing algorithm is adding more colors than the source image. These are likely to introduce this "artifacts" when going back to 8bits, mainly if the palette you're using has some color close to the background one. In this case is better to convert back to 8bits using a clean palette, without any color similar to the background. Is not a problem on your system or the program, just a bad combination of resize algorithm and palette. Try making a clean palette (before resize) and converting the images to 8bits in the advanced palette editor (after resize).

Thanks and hope people can help on our end and support the development.