YesNoOk
avatar

offset problems with helper even after i set the value? (Read 392 times)

Started by BC, April 03, 2008, 01:12:29 AM
Share this topic:

BC

offset problems with helper even after i set the value?
#1  April 03, 2008, 01:12:29 AM
  • ****
    • UK
    • www.mugenevolution.co.uk/Forum
Hi people, i have a problem i have made my first helper character the idea was to make my character call him out and he appears(which works fine) however the helper character is supposed to fire a projectile which he does but it doesnt come out near his gun it just comes out low near the floor.
i checked the offset of the projectile but not sure if i have to make a state for the projectile itself, heres the code hopefully u guys will find the problem:

[StateDef 2323]
type = S
movetype= A
physics = S
juggle  = 1
velset = 0,0
ctrl = 0
anim = 2323
poweradd = 50

[State 2323, Helper]
type = Helper
trigger1 = animelem = 8
helpertype = normal
name = "monster"
ID = 654654
stateno =  654654
pos = 20,0
postype = p1
facing = 1
keyctrl = 0
ownpal = 0
supermove = 99999
pausemove = 99999

[State 2323, end]
type=changestate
trigger1=!animtime
value=0
ctrl=1


[Statedef 654654]
type=A
physics=N
movetype=A
anim=654654
ctrl=0
velset=0,0
sprpriority=4
juggle=5

[State 654654, 1]
type = Projectile
trigger1 = AnimElem = 7
projanim = 2020
projhitanim = 5535
projpriority = 1
projheightbound = -240, 100
projedgebound = 100
projscreenbound = 100
projshadow = -1
offset = 82,-26
velocity = 3
attr = S, SP
damage   = 65
animtype = heavy
guardflag = MA
hitflag = MAFDP
pausetime = 10,10
hitsound   = 5,2
sparkxy = 500,500
guardsound = S6,0
ground.type = Low
ground.slidetime = 25
ground.hittime  = 25
ground.velocity = -6
air.animtype = Back
air.velocity = -4,-6
air.juggle = 3
air.fall = 1
down.velocity = -4,-6
down.hittime = 30
down.bounce = 0
accel = 0.7

[State 654654, end]
type = Destroyself
trigger1 = AnimTime = 0
ctrl = 1
Retired from mugen but not development

BC

Re: offset problems with helper even after i set the value?
#2  April 03, 2008, 01:26:38 AM
  • ****
    • UK
    • www.mugenevolution.co.uk/Forum
problem solved ;D, i used the yellow ruler in fighter factory for the offset guide but it seemed to be insufficent, anyway i messed around with the Y value and it needed raising to a higher minus value :D
Retired from mugen but not development