YesNoOk
avatar

server move / feb 2020 (Read 8931 times)

Started by Valodim, February 20, 2020, 01:36:58 AM
Share this topic:
server move / feb 2020
#1  February 20, 2020, 01:36:58 AM
  • ******
    • Germany
Hey folks,

just giving a heads-up that we just moved servers. The old one was terribly outdated, and I had it on my agenda to move it for a long time. Glad I could make it before we got hacked from some unpatched security issue, haha. Sorry it took a while, this forum software is old as dirt now and had some incompatibilities :P

I think I got everything working so far. Search isn't back up yet, I'll have to look into that. Please tell me if anything else looks broken to you.
Last Edit: February 20, 2020, 02:05:40 AM by Valodim
Re: server move / feb 2020
#2  February 20, 2020, 02:06:45 AM
  • ******
    • Germany
Ugh, I messed up some post code still. There's some stuff left to fix, but I'll have to deal with it later. I *hope* everything at least mostly works now.
Re: server move / feb 2020
#3  February 20, 2020, 02:14:56 AM
  • **
  • Sad, strange little man
  • "My God, jelly donuts are so scary."
    • USA
Not sure if this counts, but a little while ago I tried to change my signature, and it ended up deleting the whole thing. Also, I can't quote posts for some reason.

SIDENOTE: YOU'RE ALIVE! OH MY GOD I CAN'T BELIEVE IT!
Quote
Girls are now typing. Please wait warmly and have some tea until the signature is ready.


Go check out Team Sonic Fighters!
https://mugenguild.com/forum/topics/team-sonic-fighters-188020.0.html
Re: server move / feb 2020
#4  February 20, 2020, 03:13:17 AM
  • ****
  • Vs Style Debuts Tag Project CEO
  • The Dark Wolf Returns
    • USA
I was wondering what happened here because I tried to post and it said that the message box is empty when it wasn't.
Beware the Dark Wolf once more!
Re: server move / feb 2020
#5  February 20, 2020, 05:51:40 AM
  • ******
  • Does this look like the face of mercy?
our favorite pony princess is back! the princess of... what was it again? it started with "F". was it "fascism"? i dunno.

anyway! thanks for the update. i would also like to adress an annoying little problem we've had for a long time. if we enter an URL to our avatar with https:// it will not display anything, so we would have to change it to just http://

Won't display an avatar: https://i.imgur.com/Dd4KX0w.png
Will display an avatar: http://i.imgur.com/Dd4KX0w.png

thank you and welcome back.

Re: server move / feb 2020
#6  February 20, 2020, 09:31:38 AM
  • ******
    • Germany
Not sure if this counts, but a little while ago I tried to change my signature, and it ended up deleting the whole thing. Also, I can't quote posts for some reason.

there was a brief period where those things were broken. but they should be fixed at this point?

I was wondering what happened here because I tried to post and it said that the message box is empty when it wasn't.

yeah I was still fiddling with some code to make it work again, haha. should be ok now :)

our favorite pony princess is back! the princess of... what was it again? it started with "F". was it "fascism"? i dunno.

All those years and I still love this gimmick! It's also amazing to me that the forum software can mostly hold its own against modern alternatives. I was expecting a much shoddier experience clouded by nostalgia, but it's actually quite ok :)

Quote
anyway! thanks for the update. i would also like to adress an annoying little problem we've had for a long time. if we enter an URL to our avatar with https:// it will not display anything, so we would have to change it to just http://

I properly added https to this server, and it's enforced too (http redirects). So this should be the other way around now?
Re: server move / feb 2020
#7  February 20, 2020, 03:02:40 PM
  • ******
  • The Lord of Vampire
  • Member of the Reign of Kreation
    • Brazil
    • guiaugusto20@hotmail.com
    • Skype - guiaugusto20
Valodim, welcome back. :)

But there's a problem. Embed videos doesn't show up in the threads.
Re: server move / feb 2020
#8  February 20, 2020, 03:16:42 PM
  • ******
  • Does this look like the face of mercy?
I properly added https to this server, and it's enforced too (http redirects). So this should be the other way around now?
Well, I just tried to update my avatar URL with https:// and it keeps happening.

:-\

Re: server move / feb 2020
#9  February 20, 2020, 04:22:14 PM
  • ******
    • Germany
I'll look into it. Seems I also broke smileys along the way
Re: server move / feb 2020
#10  February 20, 2020, 04:27:02 PM
  • ******
  • The Lord of Vampire
  • Member of the Reign of Kreation
    • Brazil
    • guiaugusto20@hotmail.com
    • Skype - guiaugusto20
I tested in Firefox. Now i tested in Chrome and Edge aswell and the Embed videos still won't appear. :(
Re: server move / feb 2020
#11  February 20, 2020, 05:29:03 PM
  • ******
    • Germany
Smileys fixed. Embedded videos also better now, maybe?
Re: server move / feb 2020
#12  February 20, 2020, 05:42:25 PM
  • ******
  • 90's Kawaii
  • :thinking:
    • Guatemala
Hey Val, what does the yellow lock next to notifications mean/do?
Re: server move / feb 2020
#13  February 20, 2020, 05:47:12 PM
  • ******
    • Germany
Haha, I love how folks have been around for so long they notice these teensy details. It's an indicator that you're looking at the page with TLS encryption. Used to be that wasn't the default, but these days it's pretty backwards to serve unencrypted websites. So that lock is kinda meaningless these days..

Unfortunately the forum software makes some assumptions about http here and there, like with avatars. I think I fixed it now :P
Re: server move / feb 2020
#14  February 20, 2020, 05:54:55 PM
  • ******
  • 90's Kawaii
  • :thinking:
    • Guatemala
It was actually a new-ish member who brought it up on discord, my guess was that it was an "insecure connection" warning.
Re: server move / feb 2020
#15  February 20, 2020, 05:56:21 PM
  • *****
  • i will meditate and then write a really epic post
  • jai ho
    • Skype - executivepetrel
    • kawaiikings.net
I noticed it immediately too, but figured it was involved with encryption
youtube
●▬▬▬▬▬▬▬▬▬▬▬▬▬♥๑۩۩๑♥▬▬▬▬▬▬▬▬▬▬▬▬▬●
Put this on the profile of people who are known/wanted terrorists
that were involved in the September 11th attacks in 2001
●▬▬▬▬▬▬▬▬▬▬▬▬▬♥๑۩۩๑♥▬▬▬▬▬▬▬▬▬▬▬▬▬●
- courtesy of Iced
Re: server move / feb 2020
#16  February 20, 2020, 05:58:48 PM
  • ******
    • Germany
Removed it now, it's obviously more confusing than anything. There should be a nice green lock next to the URI in the browser to indicate that everything is nice and encrypted now :)
Re: server move / feb 2020
#17  February 20, 2020, 06:04:42 PM
  • *****
  • i will meditate and then write a really epic post
  • jai ho
    • Skype - executivepetrel
    • kawaiikings.net
Removed it now, it's obviously more confusing than anything. There should be a nice green lock next to the URI in the browser to indicate that everything is nice and encrypted now :)
Here's something I wanna ask as a favor:

Is it possible to make it so I actually appear as a Global Moderator?

I'm not in the list of Global Mods that you can access at the bottom of the forum main page. I suspect it has to do with my MFG network star being first or something. I wasn't able to solve it myself, maybe I missed something obvious though?
youtube
●▬▬▬▬▬▬▬▬▬▬▬▬▬♥๑۩۩๑♥▬▬▬▬▬▬▬▬▬▬▬▬▬●
Put this on the profile of people who are known/wanted terrorists
that were involved in the September 11th attacks in 2001
●▬▬▬▬▬▬▬▬▬▬▬▬▬♥๑۩۩๑♥▬▬▬▬▬▬▬▬▬▬▬▬▬●
- courtesy of Iced
Re: server move / feb 2020
#18  February 20, 2020, 06:06:02 PM
  • ******
    • Germany
sure
Re: server move / feb 2020
#19  February 20, 2020, 09:44:50 PM
  • ******
  • The Lord of Vampire
  • Member of the Reign of Kreation
    • Brazil
    • guiaugusto20@hotmail.com
    • Skype - guiaugusto20
Re: server move / feb 2020
#20  February 20, 2020, 10:06:35 PM
  • ***
  • I'm a llama!
Here is an issue I'm having.
I'm trying to modify my "Dxwho Sprite Packs Part 2" topic in Resource Releases in order to post a new sprite pack but I'm getting:
"Please try again. If you come back to this error screen, report the error to an administrator."
This happened yesterday when I tried and today. I'm use Firefox (if that matters).
I suppose I could "bump" the topic with a new post but its better to modify as is causes less clutter.